Item Template of RadComboBox is not working

1 posts, 0 answers
  1. Alok
    Alok avatar
    3 posts
    Member since:
    Apr 2009

    Posted 15 Apr 2009 Link to this post

    Hi All,

    I have created a custom page layout in sharepoint. In the layout I am adding a "RadComboBox" and in the ItemTemplate of this RadComboBox I am adding a "RadTreeView" control like below.


    <telerik:RadComboBox ID="RadComboBox1" runat="server"
                EnableItemBindingExpressions="true" HighlightTemplatedItems="True" OnClientSelectedIndexChanging="changing" >
              <Items>
                  <telerik:RadComboBoxItem runat="server" Text="RadComboBoxItem1"
                      Value="RadComboBoxItem1" />
              </Items>
              <ItemTemplate>
                  <div>
                      <telerik:RadTreeView ID="RadTreeView1" Runat="server" CheckBoxes="True" Skin="Black" >
                        <Nodes>
                                <telerik:RadTreeNode runat="server" Text="Node1" Value="Node1">
                                    <Nodes>
                                        <telerik:RadTreeNode runat="server" Text="ChildNode 1" Value="ChildNode 1">
                                        </telerik:RadTreeNode>
                                        <telerik:RadTreeNode runat="server" Text="ChildNode 2" Value="ChildNode 2">
                                        </telerik:RadTreeNode>
                                    </Nodes>
                                </telerik:RadTreeNode>
                                <telerik:RadTreeNode runat="server" Text="Node2" Value="Node2">
                                    <Nodes>
                                        <telerik:RadTreeNode runat="server" Text="ChildNode 1" Value="ChildNode 1">
                                        </telerik:RadTreeNode>
                                    </Nodes>
                                </telerik:RadTreeNode>
                        </Nodes>
        </telerik:RadTreeView>
                  </div>
              </ItemTemplate>
    <FooterTemplate>FOOTER</FooterTemplate>
        </telerik:RadComboBox>

    This is working fine in the simple web application showing the tree view control in the Combo box  control.
    But in my custom page layout it is not showing the tree view control.
    Is there any work around for this.

    Thanks in Advance
    Alok...
Back to Top