Item Template and Click to Open not works

2 posts, 0 answers
  1. Stalin
    Stalin avatar
    15 posts
    Member since:
    Jun 2012

    Posted 11 Dec 2013 Link to this post


    Below is my sample code where the first menu on click is not redirecting,

    <telerik:RadMenu ID="RadMenu1" runat="server" EnableRoundedCorners="true" EnableShadows="true"
            ClickToOpen="true">
            <Items>
                <telerik:RadMenuItem>
                    <ItemTemplate>
                        <a class="rmLink" href="http://www.google.com"><span class="rmText">This is the root item</span></a>
                    </ItemTemplate>
                </telerik:RadMenuItem>
                <telerik:RadMenuItem Text="Edit" AccessKey="E">
                    <Items>
                        <telerik:RadMenuItem ImageUrl="~/Menu/Images/21undo.gif" Text="Undo" AccessKey="U" />
                        <telerik:RadMenuItem IsSeparator="True" />
                        <telerik:RadMenuItem ImageUrl="~/Menu/Images/cut.png" Text="Cut" AccessKey="T" />
                        <telerik:RadMenuItem ImageUrl="~/Menu/Images/copy.png" Text="Copy" AccessKey="C" />
                        <telerik:RadMenuItem ImageUrl="~/Menu/Images/paste.png" Text="Paste" AccessKey="P" />
                        <telerik:RadMenuItem ImageUrl="~/Menu/Images/23clipboard.gif" Text="Clipboard..."
                            AccessKey="b" />
                        <telerik:RadMenuItem IsSeparator="True" />
                    </Items>
                </telerik:RadMenuItem>
            </Items>
        </telerik:RadMenu>
    Tried my best but didn't find any solution. 

    Anyone have solution ? Looking for help !

    Thanks,
    Stalin

  2. Princy
    Princy avatar
    17421 posts
    Member since:
    Mar 2007

    Posted 11 Dec 2013 Link to this post

    Hi Stalin,

    Please have a look into this online demo which deals the same scenario.

    Thanks,
    Princy.


  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top