Issues with "Test UniqueID" elements

2 posts, 0 answers
  1. Sean
    Sean avatar
    4 posts
    Member since:
    May 2014

    Posted 07 Jul 2015 Link to this post

    Hello,

     

    I am running into trouble when downloading my telerik tests that were built by an external entity. I am using Telerik to call certain tests as steps, and they continue to fail because the Unique ID assigned to the test step does not match the ID in the full run of steps. 

     

     I am looking for a solution to this that does not require that i break out each "test as step" into their own steps. From what I can tell, you can't alter the UniqueID of the step, but you can ask the tests to access a different UniqueID. This is not ideal as I would still need to alter each test to be current.

  2. Boyan Boev
    Admin
    Boyan Boev avatar
    1040 posts

    Posted 10 Jul 2015 Link to this post

    Hello Sean,

    Thank you for contacting us.

    Please elaborate a bit more on your scenario. What do you mean by "tests that were built by an external entity"?

    When you add a test as step Test Studio finds the test by its ID. If you replace that test with another one it is expected that it cannot be found.

    The workaround here is to add again the test as step.

    If I am missing something please let me know.

    Hope to hear from you soon.

    Regards,
    Boyan Boev
    Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
Back to Top