Issues with PDF export from scheduler

2 posts, 0 answers
  1. Aron
    Aron avatar
    13 posts
    Member since:
    Apr 2015

    Posted 11 Aug 2015 Link to this post

    Hello.

    I'm currently experiencing issues with the Schedulers PDF-export function. It seems that i can not set the ShowHourColumn to invisible properly, making it render the hour column in the pdf export. I do not wish for it to do this. Also, the export creates some sort of mashed together rows at the top of every page (starting at page 2 and onwards). I'm attaching an image to better show the issues that I'm experiencing. 

     

    #1 is the mashed-rows, they contain actual data that needs to be display.

     

    #2 is the hour column, i want to hide it in the export.

     Here's the code for exporting it.

    rdSchedular.ExportSettings.Pdf.PaperSize = SchedulerPaperSize.A4;
     
    rdSchedular.ExportSettings.Pdf.PaperOrientation = SchedulerPaperOrientation.Portrait;
    rdSchedular.ExportSettings.Pdf.PageTopMargin = Unit.Parse("20px");
    rdSchedular.ExportSettings.Pdf.PageBottomMargin = Unit.Parse("20px");
    rdSchedular.ExportSettings.Pdf.PageLeftMargin = Unit.Parse("20px");
    rdSchedular.ExportSettings.Pdf.PageRightMargin = Unit.Parse("20px");
     
    rdSchedular.ExportSettings.FileName = "pdfDocument"
    rdSchedular.ExportSettings.Pdf.Author = "me"
    rdSchedular.ExportSettings.Pdf.Creator = "me"
    rdSchedular.ExportSettings.Pdf.Title = "pdfDocument"
    rdSchedular.ExportSettings.OpenInNewWindow = true;
     
    rdSchedular.ExportSettings.Pdf.StyleSheets = new[] { ResolveClientUrl("~/Styles/TelSchedular.css") };
     
    rdSchedular.ExportSettings.Pdf.AllowPaging = true;
    rdSchedular.AgendaView.TimeColumnWidth = 1;
     
    BindCalendar();
     
    if (rdSchedular.SelectedView == SchedulerViewType.AgendaView)
    {
        var contr = rdSchedular.ShowHoursColumn = false;
        rdSchedular.RowHeight = 200;
     
    }
     
    rdSchedular.ExportToPdf();

  2. Ivan Danchev
    Admin
    Ivan Danchev avatar
    837 posts

    Posted 13 Aug 2015 Link to this post

    Hello,

    1. We tested the settings you apply to the RadScheduler and found that the issue with some of the rows not being displayed correctly is due to setting both: Top/Bottom margins and RowHeight. We would recommend using them alternatively - either set the margins or the RowHeight property. 

    2. Currently there is no property that would allow to hide the Time Column in AgendaView.

    Regards,
    Ivan Danchev
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top