Issue with horizontal scrolling in tabstrip within splitter

2 posts, 0 answers
  1. Arrash
    Arrash avatar
    6 posts
    Member since:
    Jun 2011

    Posted 01 Oct 2015 Link to this post

    I have a tabstrip within a splitter pane but for some reason the horizontal scrolling just doesn't seem to work - I was wondering if this cold be an issue with the splitter pane? I've desperately tried to find someone whos had a similar problem, but to no avail...


    I've attached a screen shot of what I get when some of the tabs are hidden.  rather than getting the two directional scroll buttons appear as you would expect, Only one of them is visible and it is set to 'unselectable'.  the other direction button is there but its display is set to none by default...and is also 'unselectable'


    please help!!

  2. Dimo
    Dimo avatar
    8318 posts

    Posted 05 Oct 2015 Link to this post

    Hi Arrash,

    The provided screenshot suggests that the TabStrip widget layout is broken, however, the cause is unclear. Have you tried inspecting the scroll buttons' styles to check if there are conflicting custom styles?

    Here is a runnable example, which works as expected. Please compare with your implementation and let me know if you need more information. Feel free to edit it until the described problem is exhibited and send it back for further inspection.

    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
Back to Top