Issue with Finding Telerik Controls

4 posts, 0 answers
  1. anupam
    anupam avatar
    2 posts
    Member since:
    Feb 2016

    Posted 25 Feb Link to this post

    Hi,

     

     Currently I am trying to automate a Test flow in an application which uses Telerik controls ( RadControls for WPF Q2 2013, file version: 2013.2.611.45) using Visual studio 2012 (Coded UI Test). But while trying to find the controls I am facing issues as it is finding only very few properties. [Control type, control tag, technology name = UIA].

     

    Is this correct functioning of Visual studio coded UI. If not can you please guide me about what steps to follow to rectify the error. 

     

    N.B. we already followed the steps mentioned in  "http://docs.telerik.com/devtools/wpf/coded-ui-support.html" to install the telerik control support dll in visual studio. But still facing issues.

     

    ANy help is appreciated.

     

    THanks 

    AR

  2. Tanya
    Admin
    Tanya avatar
    405 posts

    Posted 01 Mar Link to this post

    Hello,

    Could you please share the exact controls you are trying to use? Any additional details on the exact scenario will be much appreciated.

    Regards,
    Tanya
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. UI for WPF is Visual Studio 2017 Ready
  4. anupam
    anupam avatar
    2 posts
    Member since:
    Feb 2016

    Posted 01 Mar in reply to Tanya Link to this post

    Hi Tanya,

     

     Currently We are facing issues while automating any telerik controls. Issues Faced: 

    1. Unable to identify the control.

    2. Coded UI gives an error: "Last action on Row was not recorded because the control does not have any good identification property" [Refer Screenshot attached]

    Telerik Version ( RadControls for WPF Q2 2013, file version: 2013.2.611.45)[screenshot Attached].

    Visual Studio Version: 2012

     

    As mentioned before we already followed the steps mentioned in  "http://docs.telerik.com/devtools/wpf/coded-ui-support.html" to install the telerik control support dll in visual studio. But still facing this issues.

     

    Any help quickly is appreciated.

     

    Thanks 

     

    AR

  5. Tanya
    Admin
    Tanya avatar
    405 posts

    Posted 04 Mar Link to this post

    Hi,

    I am afraid that I wasn't able to reproduce a similar error. I am attaching an application to demonstrate a simple coded UI test with a RadButton. Could you try to execute your scenario using this project? Could you share the exact steps you are performing?

    Regards,
    Tanya
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top