Issue with axis labels when set to MultiLine fit and zoomed

2 posts, 0 answers
  1. Stephen
    Stephen avatar
    12 posts
    Member since:
    Sep 2013

    Posted 25 Sep 2013 Link to this post

    Hi,

    I have labels enabled on the x-axis, and have set the Axis.LabelFitMode = AxisLabelFitMode.MultiLine. This displays fine for some data, but if you also have scrolling/zooming turned on then the label positions become messed up as you zoom in and scroll to the right. The further right you go, the more lines are used for the labels (even though they can easily fit onto a single line at this zoom level). See the below images for specific details.

    Image 1 - Zoomed in, scrolled left
    http://i.imgur.com/kdViVa0.png

    Image 2 - Zoomed in, scrolled right
    http://i.imgur.com/xEdc6Sn.png

    I'm wondering is there any way to get around this or will it be fixed?
  2. Petar Kirov
    Admin
    Petar Kirov avatar
    425 posts

    Posted 30 Sep 2013 Link to this post

    Hi Stephen,

    Given the provided information, I was not able to reproduce the issue you are reporting. I have attached my test project along with screenshots of it for reference. In order to help you we will need to observe this on our side so we can investigate it. It would be best if you could provide a runable project (perhaps a modified version of the one I am attaching).

    Thanks for the understanding.
     
    Regards,
    Petar Kirov
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for SILVERLIGHT.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  3. DevCraft banner
Back to Top