IsEnabled=false does not change layout

11 posts, 0 answers
  1. Christian
    Christian avatar
    22 posts
    Member since:
    Nov 2008

    Posted 03 Jul 2009 Link to this post

    Hello

    When setting the IsEnabled property of a RedNumericUpDown control to false, there is almost no visual change. Only the control does not change its border any more when hovering over it. But there is no gray background or anything like that.
    When we experienced that, we tried to do it using a trigger and setting the Background property but the Background property does not seem to work.

    Is there any simple solution to that apart from putting a whole new ControlTemplate?

    Best regards

    Christian
  2. Hristo Borisov
    Admin
    Hristo Borisov avatar
    298 posts

    Posted 09 Jul 2009 Link to this post

    Hi Christian,

    The Background property is working in our latest version for Q2 both in Silverlight and WPF. Please download and install our latest version.We also do encourage our customers to use our latest releases in order to benefit most of our rapid development lifecycle. Thank you for contacting us and we look forward to receiving other valuable feedback.

    Kind regards,
    Hristo Borisov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. UI for WPF is Visual Studio 2017 Ready
  4. Christian
    Christian avatar
    22 posts
    Member since:
    Nov 2008

    Posted 10 Jul 2009 Link to this post

    Hi Hristo

    Thank you for your feedback. We have tested the Background property of the Q2 Version now and it's working.

    Best regards

    Christian
  5. Grzesiek
    Grzesiek avatar
    87 posts
    Member since:
    Jun 2007

    Posted 24 Mar 2012 Link to this post

    It seems, that in Q1 2012 it doesn't work again. I have the same problem and after switching from IsEnabled=true to false there is no change in layout.

    I'm using Summer template.
  6. Konstantina
    Admin
    Konstantina avatar
    2332 posts

    Posted 28 Mar 2012 Link to this post

    Hi Grzesiek,

    I have tested this issue with the latest assemblies, but there seems to be no problem. Could you please elaborate more on the issue.
    By design the Summer theme has no dark background when the NumericUpDown is disabled, only the buttons get greyed out.

    All the best,
    Konstantina
    the Telerik team
    Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
  7. MATEUSZ
    MATEUSZ avatar
    18 posts
    Member since:
    Jul 2011

    Posted 10 Apr 2012 Link to this post

    Hi, I have experienced similar issue on office_blue theme.

    http://rad-studio.pl/Media/radnumericupdown.wmv <--- video file presenting the problem, couldnt attach it to the post

    IsEnabled property of the radnumericupdown is attached to a boolean property of a viewmodel, which is initially set to true. As you can see, it has reamarkably "dark"/blue/inactive background, but it should not. When I enter mouse in the area of the control, it gets white/active/proper background. Changing value of combobox should sett mentioned bool property to false. And it causes controls' inactive state - but it impacts updown buttons only.

    I'm using latest hotfix for q1. 
  8. Konstantina
    Admin
    Konstantina avatar
    2332 posts

    Posted 13 Apr 2012 Link to this post

    Hello Mateusz,

    I wasn't able to reproduce the issue using the Q1 2012 SP1 version of the control. Instead of ComboBox I have bound the NumericUpDown control to a CheckBox and to the ViewModel.
    Please find attached a short video which illustrated my attempt.
    If you could send us a sample project which reproduces the issue it will be very helpful for tracking down the source of the problem.

    All the best,
    Konstantina
    the Telerik team
    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>
  9. MATEUSZ
    MATEUSZ avatar
    18 posts
    Member since:
    Jul 2011

    Posted 18 Apr 2012 Link to this post

    Guys, are you kidding me?

    I didn't have time to investigate this case, but many people are writing about this problem and you can't bind two controls together to check if it works properly on your newest radcontrols?

    And why can't I attach zip file?

    http://rad-studio.pl/Media/RadControlsWpfApp1.zip link to solution presenting this problem

    <StackPanel Orientation="Horizontal">
        <telerik:RadToggleButton x:Name="toggleButton" Content="change updown isenabled"/>
        <telerik:RadNumericUpDown IsEnabled="{Binding ElementName=toggleButton, Path=IsChecked}"/>
    </StackPanel>

    this piece of xaml is more than enough to show issue. tested on sp1 and latest internal build, behaviour same as shown on video. and you can't tell me it's expected behavior. either you don't disable "inside textbox" at all, or you deal it correctly.

    In addition, I'm creating official bug report.
  10. Konstantina
    Admin
    Konstantina avatar
    2332 posts

    Posted 19 Apr 2012 Link to this post

    Hello Mateusz,

    Thank you for the sample project.

    Initially, when you need to attach a file you have to open a support ticket, as you already did. We will research the issue and provide a fix in one of the next internal builds.
    Sorry for the caused inconvenience.

    Regards,
    Konstantina
    the Telerik team
    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>
  11. Christian
    Christian avatar
    52 posts
    Member since:
    Apr 2011

    Posted 08 May 2012 Link to this post

    Hi,
    I also have this issue.
    Is it fixed with the new internal build?If not, is there a PITS entry which I can observe?

    Best Regards
  12. MATEUSZ
    MATEUSZ avatar
    18 posts
    Member since:
    Jul 2011

    Posted 08 May 2012 Link to this post

    at q1.430 works fine
Back to Top
UI for WPF is Visual Studio 2017 Ready