Is Spell Check supported in Safari?

7 posts, 0 answers
  1. Travas Nolte
    Travas Nolte avatar
    6 posts
    Member since:
    Aug 2012

    Posted 12 Dec 2008 Link to this post



    I have RadGrid with modal popup edit form, in that form I have TextArea and a RadSpell control to do spellchecking.

    All works good in IE and FF, but when I try it in Safario (3.2.1), it displays the dialog, but doesn't populate the text from the textarea into the Spell Check dialog.

    Any ideas?
  2. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 16 Dec 2008 Link to this post

    Hi Travas,

    Unfortunately, we are not aware of this problem and you are the first to report it.

    Could you please, open a support ticket and send a sample fully runnable project that demonstrates the Safari problem? We will examine it right away and do our best to provide a solution.

    Kind regards,
    Rumen
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 16 Dec 2008 Link to this post

    Hi Travas,

    I tried to reproduce the problem using the code of the PopUp edit form example and I was not able to reproduce the reported problem in Safari. You can see the attached screenshot for more information.

    The only problem that I faced was that the spellcheck dialog is positioned below the PopUp edit form window. If this is your problem I can send you a solution. Just let me know.

    All the best,
    Rumen
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  5. Travas Nolte
    Travas Nolte avatar
    6 posts
    Member since:
    Aug 2012

    Posted 16 Dec 2008 Link to this post


    No. The postioning was a problem initially, but I was able to get that worked out by adjusting the z-index on my controls.

    I have workable solution, but tied to my LINQ datasource. Let me get the dependencies of that removed and I will send a working solution.

    Additional note:
    I am using the 3.5 version and connecting to the RadGrid via LINQDataSource. Just an FYI, don't think it related but wanted to let you know.


    Thanks,
    Travas
  6. Travas Nolte
    Travas Nolte avatar
    6 posts
    Member since:
    Aug 2012

    Posted 16 Dec 2008 Link to this post

    Rumen,

    I have working solution to send to you to replicate the issue I am having with Safari, but I don't see an option to attached a .zip file.

    Do I need to create a new thread or can I email it to you directly?

    Thanks,
    Travas

  7. Travas Nolte
    Travas Nolte avatar
    6 posts
    Member since:
    Aug 2012

    Posted 16 Dec 2008 Link to this post

    Rumen,

    I also just noticed that your test is using Safari version (3.1.2) and my test are on Safari version (3.2.1).

    Travas
  8. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 19 Dec 2008 Link to this post

    Hi Travas,

    Thank you for the additional information. I updated my Safari version to the latest one 3.2.1 and I was not able to reproduce the issue again.

    Nevertheless, we are currently examining your project attached to your support ticket on the subject and we will write back with more information later today.

    The forums do not support attachments and the only way is to use the attachment functionality of the support ticketing system to send a file.

    Kind regards,
    Rumen
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017