iOS build error for the latest version

4 posts, 1 answers
  1. FS
    FS avatar
    15 posts
    Member since:
    Mar 2012

    Posted 19 Sep Link to this post

    Hi Support:

    After evaluating the product we decided to buy the product today.

    We added the new dlls (R3 2016 v 2016.3.914) in PCL, Droid and iOS.  Running the project in Android works fine as always, but when we try tu build the project in iOS we got this strange reason that did not happened before:

     

    Can not resolve reference: C:/Program Files (x86)/Reference Assemblies/Microsoft/Framework/Xamarin.iOS/v1.0/Facades/System.Private.CoreLib.InteropServices.dll

    We are using Xamarin Forms version 2.3.1.114. 

    Our IDE is Visual Studio 2015, and we are using MacInCloud for iOS build machine.

    This was running fine before this upgrade.

    How could I debug this.

    Thanks

     

    David





     

     

     

     

     

  2. FS
    FS avatar
    15 posts
    Member since:
    Mar 2012

    Posted 19 Sep in reply to FS Link to this post

    Hi Support:

    I opened the sample project that came in your msi and I got the same error, so at least we know that is not related with my source code.

     

    I will be waiting for your help on this.

    Thanks

    David

     

  3. DevCraft banner
  4. Answer
    Tsvyatko
    Admin
    Tsvyatko avatar
    833 posts

    Posted 20 Sep Link to this post

    Hello,


    Thank you for contacting us. Generally such issues indicate the inconsistency of versions between the Windows and Mac machines.

    Would it possible to validate whether the VS 2015 is updated on the windows machine as well as the xamarin studio on mac is updated to the latest version. Also, please check the version of the xcode installed. 

    Regards,
    Tsvyatko
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  5. FS
    FS avatar
    15 posts
    Member since:
    Mar 2012

    Posted 20 Sep in reply to Tsvyatko Link to this post

    Hi Tsvyatko:

    Thanks for your help, because you were right.  The XCode in the Mac server was upgraded, so I just upgraded the Visual Studio 2015 Xamarin part and now everthing is ok.

     

    David

     

     

Back to Top
DevCraft banner