iOS Build Error

15 posts, 0 answers
  1. Andrew
    Andrew avatar
    18 posts
    Member since:
    Jul 2012

    Posted 19 Jul 2012 Link to this post

    Hi, when i build using my current provisioning profile the following error is given. It also errors in the cloud too. Any suggestions?

    [2012-07-19 11-11-06-00] Log (Info,None): Version 2012.2.606.2. Deployment location app.icenium.com.
    [2012-07-19 11-11-27-44] Log (Info,None): Logged in as: adcarrington@live.co.uk
    Loading extension DeviceManagement.
    Loading extension ProjectNavigator.
    Loading extension MSBuildCore.
    Loading extension iOS.
    Loading extension Android.
    Loading extension Callback.
    Loading extension DocumentNavigation.
    Loading extension TextEditor.
    Loading extension CodeAnalysisIntegration.
    Loading extension FindReplaceModule.
    Loading extension ErrorReporting.
    Loading extension MagicBox.
    Loading extension MobileSimulator.
    GeoLoc Synchronized.
    [2012-07-19 11-12-34-92] Log (Info,Low): Found device EBusiness2
    Project "GeoLoc.sln" (Build target(s)):
    Project "GeoLoc.proj" (default targets):
    Exec: : Error C:\Program Files (x86)\MSBuild\Telerik\ICE\Tools\Mobile\MobileTools.targets(101,3): The command ""C:\Program Files (x86)\MSBuild\Telerik\ICE\Tools\Mobile\Signer\MacSigner.Client.exe" "adcarrington_live.co.uk\GeoLoc\GeoLoc\bin\iOS\Debug\Payload\Cordova170.app" "adcarrington_live.co.uk\_MobileProvisions\developer_identity.cer" """ exited with code -1.
    Done building project "GeoLoc.proj" -- FAILED.
    Done building project "GeoLoc.sln" -- FAILED.

    Thanks
    Andy
  2. Yavor
    Yavor avatar
    25 posts
    Member since:
    May 2009

    Posted 19 Jul 2012 Link to this post

    Hi Andy,

    We'll look into this right away and get back to you the moment we have resolved this.

    Stay tuned.
  3. Andrew
    Andrew avatar
    18 posts
    Member since:
    Jul 2012

    Posted 19 Jul 2012 Link to this post

    Great, thanks.
  4. Yavor
    Yavor avatar
    25 posts
    Member since:
    May 2009

    Posted 20 Jul 2012 Link to this post

    Hi Andy,

    It seems that the developer profile you have cannot be parsed by Icenium. Have you imported it from Keychain Access on a Mac, or have you created it in Icenium?

    Regards,
    Yavor
  5. Andrew
    Andrew avatar
    18 posts
    Member since:
    Jul 2012

    Posted 20 Jul 2012 Link to this post

    Hi Yavor

    This was created in keychain for me by our corporate dev program admin.

    Thanks
    Andy

  6. Yavor
    Yavor avatar
    25 posts
    Member since:
    May 2009

    Posted 20 Jul 2012 Link to this post

    Hi Andy,

    In this case, could you please ask your program admin to export the codesigning identity from the keychain again, but this time not protect it with a password? Support for importing password-protected identities will come in our next beta.

    Regards,
    Yavor
  7. Andrew
    Andrew avatar
    18 posts
    Member since:
    Jul 2012

    Posted 23 Jul 2012 Link to this post

    Hi Yavor

    I now have a file without a password and I have used it to build the app. This now builds and generates the ipa file. Unfortunately it doesn't install to my device...not sure if its an issue in our provisioning or not yet, I will investigate it. 

    The failure says "C5C2Z5JZ9R.com.covidien.newsfeed failed to install". Our provisioning is set under com.covidien.newsfeed...is Icenium adding something extra that the device / profile doesn't like?

    Thanks
    Andy

  8. Yavor
    Yavor avatar
    25 posts
    Member since:
    May 2009

    Posted 23 Jul 2012 Link to this post

    Hi Andy,

    If you mean the sequence of characters before "com.covidien.newsfeed" - that is the App Identifier Prefix and it comes from the mobile provision you have chosen. It gets attached to your app as part of the codesigning process.

    Could you please share more details about your provision - is it a Developer or Ad-hoc? Also, could you share your Graphite logs?

    Regards,
    Yavor
  9. Andrew
    Andrew avatar
    18 posts
    Member since:
    Jul 2012

    Posted 23 Jul 2012 Link to this post

    Hi Yavor

    Great thanks for the info...this is all rather new for us :)

    The provision is a developer provision. We use MobileIron here to serve internal apps. So each developer has developer provisions / certs and then a central control actually "live signs" the apps for distribution through MI.

    I am currently using mist as graphite doesn't sync my provisioning certs...hence no graphite logs :(

    When using graphite I receive the attached error when editing the mobile section under user options.

    Thanks
    Andy

  10. Yavor
    Yavor avatar
    25 posts
    Member since:
    May 2009

    Posted 23 Jul 2012 Link to this post

    Hi Andy,

    The Graphite error is rather strange. I'll see if our logs can show anything about it.

    However, you will need to build your app with an Ad-hoc provision if you want to deploy it using the QR code in Mist.

    Developer provision IPAs can only be deployed from Graphite or iTunes. You will need to download the IPA, add it to iTunes and then sync it to your device.

    Regards,
    Yavor

  11. Andrew
    Andrew avatar
    18 posts
    Member since:
    Jul 2012

    Posted 23 Jul 2012 Link to this post

    Thanks for your help with this Yavor. Looking forward to see if your logs show anything.

    Andy
  12. Yavor
    Yavor avatar
    25 posts
    Member since:
    May 2009

    Posted 23 Jul 2012 Link to this post

    Hi Andy,

    Our server logs show that one of your provisions has more than one developer certificate in it. Unfortunately, this is not a scenario we support well in this release.

    Could you please remove the provision from Mist and import a new one, with only one certificate?

    Regards,
    Yavor
  13. Andrew
    Andrew avatar
    18 posts
    Member since:
    Jul 2012

    Posted 23 Jul 2012 Link to this post

    I will get this reissued if I can and let you know how I get on.

    Thanks
    Andy

  14. Andrew
    Andrew avatar
    18 posts
    Member since:
    Jul 2012

    Posted 13 Aug 2012 Link to this post

    I have tested the new version with both password secured developer certificates (P12) and multi-device provisioning profiles...both work as expected and I have tested on my device and this works great!

    Thanks
    Andy

  15. Yavor
    Yavor avatar
    25 posts
    Member since:
    May 2009

    Posted 15 Aug 2012 Link to this post

    Hi Andy,

    I'm glad our new beta has fixed those issues for you. Don't forget to keep the feedback coming :)

    Yavor
Back to Top