iOS App Store Compatibility Requires iOS 5 or later

6 posts, 0 answers
  1. Darren
    Darren avatar
    32 posts
    Member since:
    Sep 2013

    Posted 24 Jul 2014 Link to this post

    Hi

    Can you tell me how to change my project so when I build it for publishing to the App Store the compatibility says iOS6.1 or later. The default blank project causes an App to be built with compatibility of iOS5 or later.
    I assume it is a plist or config.xml setting

    Thanks
    Darren
  2. Kaloyan
    Admin
    Kaloyan avatar
    872 posts

    Posted 28 Jul 2014 Link to this post

    Hi Darren,

    Unfortunately, at this stage it is not possible to set the minimum iOS version manually. We do this automatically, depending on the Cordova version used inside your project. For Cordova version less than 3.5 we built the application for iOS 5 and later and for Cordova 3.5 we built the app for iOS 6.1 and later.

    However, currently there is a bug on our side that ignores the Cordova 3.5 minimum iOS version setting. The good news is that the bug is already fixed and the fix will be included in the upcoming AppBuilder 2.4 release, scheduled for this week.

    I hope this helps. Further, please elaborate a bit more on the matter if the above doesn't sound reasonable for you. I will be glad to hear your point of view.

    Regards,
    Kaloyan
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  3. Darren
    Darren avatar
    32 posts
    Member since:
    Sep 2013

    Posted 29 Jul 2014 in reply to Kaloyan Link to this post

    Thanks Kaloyan

    How do I know when AppBuilder 2.4 is released? I can't find a page in AppBuilder stating the version.

    Also I think it would be a valuable addition to AppBuilder to be able to specify the version of iOS and also the Android SDK min/target/max version.
    It is not always dependent on cordova as to what versions of ios and android a user would like to target.
    (ie. if using IONIC it support iOS 6 and above)
    Thanks
    Darren


  4. Kaloyan
    Admin
    Kaloyan avatar
    872 posts

    Posted 31 Jul 2014 Link to this post

    Hi Darren,

    I am glad to say that, we have just released AppBuilder 2.4.

    Further, as AppBuilder is an Integrated Cloud Environment (ICE), its clients are forced to always use the latest version. So, each of them should automatically prompt you that it requires an update. However, you can check the latest applied version and its release notes, here.

    As for the option to specify the min iOS version, I strongly recommend posting it to our Ideas and Feedback portal. I believe it will find a lot of supporters there and will prioritized accordingly, among the other requests.

    For the Android SDK min version, you can set it from the AndroidManifest.xml. Look for the following tag:
    <uses-sdk android:minSdkVersion="8" />

    I hope this helps.

    Regards,
    Kaloyan
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  5. Darren
    Darren avatar
    32 posts
    Member since:
    Sep 2013

    Posted 31 Jul 2014 in reply to Kaloyan Link to this post

    Thanks Kaloyan

    I did know about the Android min/target/max versions in the manifest - was more thinking it would be nice to have control over it in the ide - likewise for iOS version.

    Cheers
    Darren
  6. Zdravko
    Admin
    Zdravko avatar
    657 posts

    Posted 05 Aug 2014 Link to this post

    Hello Darren,

    Thanks for your suggestion. We will have it in mind for our future releases.

    Regards,
    Zdravko
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
Back to Top