Invalid Certificate

5 posts, 0 answers
  1. Josh
    Josh avatar
    2 posts
    Member since:
    Sep 2013

    Posted 24 Sep 2013 Link to this post

    Hi,

    I'm trying to build for ios device with a development provision and am getting an "invalid certificate" error in graphite. I tried using the web version of the ide and while uploading it just sat there doing nothing, so I followed the instructions here: http://docs.icenium.com/code-signing-your-app/configuring-code-signing-for-ios-apps/create-csr ... all the way through to  with graphite.


    Thanks,
    Josh

  2. Josh
    Josh avatar
    2 posts
    Member since:
    Sep 2013

    Posted 24 Sep 2013 Link to this post

    Nevermind. The problem wasn't with that process. I downloaded a previously used mobile prevision, instead of creating a new one with the new certificate for icenium. There are so many things to hate about apple's developer portal.
  3. Matthew
    Matthew avatar
    16 posts
    Member since:
    Feb 2011

    Posted 04 Feb 2014 Link to this post

    Hi,

    I'm having the same problem. Can you please tell me what you did to solve it?

    Thanks so much.

    - Matt
  4. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 07 Feb 2014 Link to this post

    Hello Matt,

    According to Josh's explanation, he did not import the correct matching provision and certificate. Apple's dev program requires you to follow certain procedure in order to be able to build and install an app on your iOS device. We did our best to highlight most important parts including the integration withing AppBuilder in our documentation. Please review carefully the Configuring Code Signing for iOS Apps help section to get started.

    Regards,
    Steve
    Telerik
    Icenium is now Telerik AppBuilder, and is part of the Telerik Platform. For more information on the new name, and to learn more about the Platform, register for the free online keynote and webinar on Wednesday, February 12, 2014 at 11:00 a.m. ET (8:00 a.m. PT)
  5. Matthew
    Matthew avatar
    16 posts
    Member since:
    Feb 2011

    Posted 17 Feb 2014 Link to this post

    The problem is solved. Like Josh, I imported the provisioning profile but what is not obvious is you must also import the P12 certificate export file used to create the provisioning profile. The reason this is not obvious is it appears to have been brought in with the provisioning profile on the build dialog (shows a certificate but in fact there isn't on imported).
Back to Top