Internet Explorer (8 and 7) don't display Modal background overlay

10 posts, 0 answers
  1. Sam
    Sam avatar
    6 posts
    Member since:
    Jul 2010

    Posted 28 Jul 2010 Link to this post

    Unlike every other browser, Internet Explorer (8, 8 compatibility mode, 7) does not display the background overlay that grays out the background and makes everything outside of the window unclickable when Modal is set to true. There are no Javascript errors and looking at the source you see that "<div style="position: absolute; left: 0px; top: 0px; z-index: 3000; background-color: rgb(170, 170, 170); opacity: 0.5; width: 1387px; height: 1574px;" unselectable="on" class="TelerikModalOverlay"></div>" isn't there when using Internet Explorer, even though it is for Firefox. I can't find anyone else with this problem after searching Google and these forums.
  2. Georgi Tunev
    Admin
    Georgi Tunev avatar
    7207 posts

    Posted 30 Jul 2010 Link to this post

    Hi Sam,

    Can you reproduce the same problem in any of our online demos? If you do, are you by any chance using a laptop?
    I am asking this because, for showing the modal overlay in IE, we are using CSS filter, that is a DirectX component. If you are using an old version of DirectX or the computer does not have enough free resources (usually this happens with laptops), the browser will not display the modal overlay.

    If the problem exists in your application only, please open a support ticket and send us a project that reproduces it so we can investigate further.

    Kind regards,
    Georgi Tunev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Sam
    Sam avatar
    6 posts
    Member since:
    Jul 2010

    Posted 30 Jul 2010 Link to this post

    The Demos are actually working fine- I see the same TelerikModalOverlay div as I am seeing in Firefox. I am using a laptop, but it's packing a NVidia 9600M GT, so that's not a problem.
  5. Georgi Tunev
    Admin
    Georgi Tunev avatar
    7207 posts

    Posted 04 Aug 2010 Link to this post

    Hello Sam,

    If the demos are working as expected when viewed from the same laptop, it is possible that the problem is somewhere else. Can you provide a live Url or a sample project where this behavior can be observed?


    Kind regards,
    Georgi Tunev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Sam
    Sam avatar
    6 posts
    Member since:
    Jul 2010

    Posted 04 Aug 2010 Link to this post

    I will work on providing a sample.

    After many hours of debugging the other day I was able to get the overlay to work in a temporary-sense two different ways.

    1. If I save my page to my computer with Firefox (right-click -> Save Page As) and open this file up with IE8, the overlay works as expected.

    2. If I save the page to my computer using IE8 it still doesn't work. However, if I open up the page in Microsoft Expression Web 3 and I "Apply XML formatting rules" to the document and save it: the overlay works when opening this up in IE8.

    I haven't made any conclusions yet, since I still can't seem to be able to fix it by hand and the changes made by Expression Web appear to only rearrange the attributes of the elements and normalize the quotes used around attributes. So the issue must either be with the validation of our pages, the encoding, or styles.
  7. Georgi Tunev
    Admin
    Georgi Tunev avatar
    7207 posts

    Posted 09 Aug 2010 Link to this post

    Hello Sam,

    I am afraid that at this point I cannot tell what might be the problem neither. If you manage to isolate the problem in a sample project, please send it to us and we will check it.


    Sincerely yours,
    Georgi Tunev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  8. Sam
    Sam avatar
    6 posts
    Member since:
    Jul 2010

    Posted 09 Aug 2010 Link to this post

    The problem is the Internet Explorer Compatibility Header.

    Solved by inserting the following into web.config:

    <system.webServer>
    <httpProtocol>
    <customHeaders>
    <clear />
    <add name="X-UA-Compatible" value="IE=IE8" />
    </customHeaders>
    </httpProtocol>
    </system.webServer>

    Reference: http://207.46.16.252/en-us/library/dd638355%28WS.10%29.aspx

    It's also evident this wasn't a problem on live servers: "By default, Internet Explorer 8 renders Internet sites in IE8 standards mode and intranet sites in IE7 emulation mode. Because Internet pages automatically default to standards mode, users may experience issues with Web pages that do not explicitly opt-in to that mode. You can enable a page to explicitly opt-in to standards mode by using one of the following techniques:"
  9. Georgi Tunev
    Admin
    Georgi Tunev avatar
    7207 posts

    Posted 10 Aug 2010 Link to this post

    Hello Sam,

    It is good to know that everything is working fine now. And thank you for the feedback - it will be of help to other users that might get such problem.

    Greetings,
    Georgi Tunev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  10. Jay Mehta
    Jay Mehta avatar
    12 posts
    Member since:
    Sep 2009

    Posted 13 Mar 2011 Link to this post

    Hi, I am facing the same issue when using radtooltip manager and its modal background overlay in Internet Explorer. I tried adding the extra lines in web.config, but it does not resolve the issue.

    Any other suggestions?

    Thank you,
    Jay Mehta.
  11. Georgi Tunev
    Admin
    Georgi Tunev avatar
    7207 posts

    Posted 17 Mar 2011 Link to this post

    Hi Jay,

    In such case it would be best to send us a small sample project where the problem can be reproduced and we will check it right away.


    Regards,
    Georgi Tunev
    the Telerik team
    Registration for Q1 2011 What’s New Webinar Week is now open. Mark your calendar for the week starting March 21st and book your seat for a walk through all the exciting stuff we ship with the new release!
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017