Internet explorer 10 SSL Mixed Content

3 posts, 0 answers
  1. Zaid
    Zaid avatar
    2 posts
    Member since:
    Dec 2011

    Posted 26 Jul 2013 Link to this post

    Hi,

    I'm using the analytics provider in a Silverlight application over an SSL connection. When loading the application in Internet Explorer the browser brings up a dialog window asking "Display mixed content". This doesn't happen in Chrome. So I'm wondering if there is something that IE recognises within the analytics provider as insecure. Any solutions to this issue are welcome?

    Thanks
    Z
  2. Soren
    Admin
    Soren avatar
    44 posts

    Posted 26 Jul 2013 Link to this post

    Hi Zaid,

    It is not an issue we are familiar with. We are using the Silverlight monitor ourselves in our web dashboard(which is a Silverlight app) and  we have not seen the mixed content warning (and hopefully, neither have you).

    One issue you might run into that could trigger this has to do with configuring the monitor. More specifically, making sure that it is configured to use SSL if your site is loaded using https and vice versa. I'm guessing here, but if the hosting application is not loaded using the same protocol you might be getting the mixed content warning.

    Let me know if this helps

    Regards,
    Soren
    Telerik
    JAVASCRIPT MONITOR (BETA) AVAILABLE FOR DOWNLOAD.
    Monitor web applications with the new EQATEC Application Analytics JS library. Compatible with all modern browsers.
    Test it today >>
  3. Zaid
    Zaid avatar
    2 posts
    Member since:
    Dec 2011

    Posted 26 Jul 2013 Link to this post

    Hi Soren,

    Thanks for that. As you mentioned all I needed to do was set the monitor to enable SSL in its settings and it worked.

    Thanks
    Zaid
Back to Top