Installation: You must have Administrative rights...

2 posts, 0 answers
  1. John
    John avatar
    2 posts
    Member since:
    Nov 2011

    Posted 31 Jan 2012 Link to this post

    Am am new to Telerik controls.  I just downloaded my licensed installer (Telerik.Web.UI_2011_3_1305_Dev.msi) and it tells me "You must have Administrative rights on this machine to install Telerik RadControls for ASP.NET AJAX Q3 2011 SP1. Setup will now exit."

    Thing is, I do have administrative rights.  I tried creating the installation folder in advance and clearing the downloaded file 'block' flag.  No luck.

    Is there a an installation log somewhere that shows the error?



    Background:

    1. Installed Telerik evaluation in Dec.
    2. Purchased package from Telerik.
    3. Downloaded licensed package.
    4. Ran licensed package, it said the controls were already installed.
    5. Weeks later, I got evaluation version errors.
    6. Uninstalled evaluation version.
    7. Ran licensed package, it said my installer was out of date.
    8. Downloaded licensed package again.
    9. Ran new licensed package, it says I am not Administrator.

  2. John
    John avatar
    2 posts
    Member since:
    Nov 2011

    Posted 31 Jan 2012 Link to this post

    Fixed!

    When viewing the context menu of an msi file in explorer, there is no "Run as administrator" because the installer gets implicit administrator rights - unless your organization likes to fiddle with polices to limit administrative actions.

    So I ran a command line with elevated permissions and started the msi from there. 

  3. DevCraft Release
Back to Top