Installation Error with Telerik Installer

17 posts, 0 answers
  1. Jason Linden
    Jason Linden avatar
    9 posts
    Member since:
    Nov 2007

    Posted 17 Jan 2012 Link to this post

    Hey guys,

    When running the installer, I get the following error:

     ---------------------------
    Error
    ---------------------------
    System.ComponentModel.Win32Exception: Access is denied
       at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
       at System.Diagnostics.Process.Start()
       at Bootstrapper.Bootstrapper.RunFile()
       at Bootstrapper.MainForm.RunApplication()

    This occurs at the Extracting: Telerik.OperationFramework.dll step.

    I have admin rights... could this be my AV blocking it?
  2. Jason Linden
    Jason Linden avatar
    9 posts
    Member since:
    Nov 2007

    Posted 17 Jan 2012 Link to this post

    Just answered my own question. It was my McAfee. After disabling the AV features, it installed successfully :) 
  3. DevCraft banner
  4. Sam
    Sam avatar
    6 posts
    Member since:
    Jan 2012

    Posted 18 Jan 2012 Link to this post

    I am getting the exact same "Access is denied" issue on my computer. I also have McAfee. However, my McAfee settings are controlled by admin, and I am not able to disable or modify any of my McAfee settings.

    Are there any other ways around this problem?
  5. Jason Linden
    Jason Linden avatar
    9 posts
    Member since:
    Nov 2007

    Posted 18 Jan 2012 Link to this post

    My settings are controlled by admin also, but the McAfee suite still let me disable those items. Can you try that or does it not even let you open the suite?
  6. Sam
    Sam avatar
    6 posts
    Member since:
    Jan 2012

    Posted 18 Jan 2012 Link to this post

    I can open the McAfee suite, but all of the buttons are greyed out, including the ones that say "Disable". So, it doesn't look like a way for me to disable McAfee myself without going to admin (and I don't see them allowing me to disable it). I can't imagine that everyone who installs this software has to disable or turn off their antivirus.
  7. Jan Blessenohl
    Admin
    Jan Blessenohl avatar
    707 posts

    Posted 19 Jan 2012 Link to this post

    Hello guys,
    can you produce an installer log file for us? Please open a command shell in admin mode and execute:

    msiexec /l* c:\log.txt /i Telerik-OpenAccess-ORM.msi

    The resulting log file should contain more information.

    Kind regards,
    Jan Blessenohl
    the Telerik team

    SP1 for Q3’11 of Telerik OpenAccess ORM is available for download

  8. Sam
    Sam avatar
    6 posts
    Member since:
    Jan 2012

    Posted 19 Jan 2012 Link to this post

    Although I'm getting the same exact error, it is occurring while trying to install the ASP.NET AJAX controls, not OpenAccess.
  9. Jan Blessenohl
    Admin
    Jan Blessenohl avatar
    707 posts

    Posted 19 Jan 2012 Link to this post

    Hi,
    I just tested it with the latest McAffee version and the OpenAccess installer worked fine. I am using:

    1/19/2012 6:01:45 PM  Engine version                          = 5400.1158
    1/19/2012 6:01:45 PM  AntiVirus   DAT version                 = 6593.0

    You can see that by opening the statistics from the tray and clicking Properties->Reports->View Log

    Thanks for your help,
    Jan Blessenohl
    the Telerik team

    SP1 for Q3’11 of Telerik OpenAccess ORM is available for download

  10. Jason Linden
    Jason Linden avatar
    9 posts
    Member since:
    Nov 2007

    Posted 19 Jan 2012 Link to this post

    I tried this install on another machine and got the same error as before.But I think I found the offending component of McAfee. Before I just disabled everything. This time I only disabled IPS. Disabling IPS allows the installer to work. With it enabled I got the same error. Some more information on my system and what I tried:

    When I tried to use the command line to create the log I got:

    "This installation package could not be opened.  Contact the application vendor to verify that this is a valid Windows Installer package."

    Here's the info for the McAfee Host Instrusion and the McAfee AV:

    McAfee Host Instrusion
    License Type:  Licensed

    Created On:  Wednesday, January 13, 2010
    Product Version:  7.0.0
    Build Number:  1102
    Security Content Version: 4069

    System Information 
    Computer Name: A4810965
      
    McAfee Agent 
    Version number: 4.5.0.1810
    Managed 
    Last security update check: 1/19/2012 8:46:28 AM
    Last agent-to-server communication: 1/19/2012 7:36:44 AM
    Agent to Server Communication Interval (every): 3 hours
    Policy Enforcement Interval (every): 3 hours
    Agent ID: {7A1E68C6-7623-4ADE-B04A-A9BB3ABC5A85}
    ePO Server/Agent Handler 
    DNS Name: nt-epo-blv-02.nw.nos.boeing.com
    IP Address: 130.247.14.108
    Port Number: 443 
       
    Host Intrusion Prevention 7.0.0 
    Version number: 7.0.0.1102
    Language: English (United States) 
       
    Safeboot Device Encryption 
    Version number: 5.2.3
    Language: English (United States) 
      
    McAfee AntiSpyware Enterprise Module 
    Version number: 8.7.0.129
    Language: Multiple 
      
    VirusScan Enterprise + AntiSpyware Enterprise 
    Version number: 8.7i (8.7.0.570)
    Build date: 1/7/2010 
         
    Scan engine version (32-bit): 5400.1158
      
    DAT version: 6593.0000
    DAT Created on: 2012/01/18
      
    Number of Signatures in extra.dat: 0
    Name of threats that extra.dat can detect: None 
    Buffer Overflow and Access Protection DAT version: 467
      
    Installed Patches: 3
      
    Installed Modules: 
      Anti-spyware 
      License Type: licensed

  11. Sam
    Sam avatar
    6 posts
    Member since:
    Jan 2012

    Posted 19 Jan 2012 Link to this post

    Thanks Jason. You pointed me in the right direction to find the error on my side as well. It is being blocked by McAfee Host Intrusion Prevention. When I access the McAfee activity logs, this is the error below that McAfee is giving. Again, I am installing ASP.NET AJAX controls, not OpenAccess ORM, but it could be the same issue.

    Application: Bootstrapper
    Attack type: Suspicious Double File Extension Execution
  12. Jan Blessenohl
    Admin
    Jan Blessenohl avatar
    707 posts

    Posted 19 Jan 2012 Link to this post

    Hello,
    Very weird. Did you unzip the msi into a seperate folder before starting it via command line?

    Greetings,
    Jan Blessenohl
    the Telerik team

    SP1 for Q3’11 of Telerik OpenAccess ORM is available for download

  13. Jason Linden
    Jason Linden avatar
    9 posts
    Member since:
    Nov 2007

    Posted 19 Jan 2012 Link to this post

    I don't have an .MSI, only the Telerik_OpenAccess_ORM_Trial_Installer_Q3_2011_SP1.exe... which is probably why I got that "Not a valid .MSI". Unzipping that .exe doesn't give a .MSI either.
  14. Erjan Gavalji
    Admin
    Erjan Gavalji avatar
    1455 posts

    Posted 20 Jan 2012 Link to this post

    Hi guys,

    Thanks for sharing that!

    Indeed, there is an issue with MCafee and the Telerik Trial Web Installer right now. It is that the Trial installer uses a bootstrap mechanism, which seems a way some viruses operate.

    The Telerik bootstrap is signed with a Verisign CodeSigning service certificate, which is the waranty that the file is really coming from Telerik.

    We contacted the MCafee team and we're waiting for their response. I'll notify you once we get a reply.

    In the meantime, if you aren't able to switch your antivirus off, you could use the MSI installers, available in the following page:

    http://www.telerik.com/offline-trial-download.aspx 

    I hope this helps.

    Kind regards,
    Erjan Gavalji
    the Telerik team

    SP1 for Q3’11 of Telerik OpenAccess ORM is available for download

  15. Sam
    Sam avatar
    6 posts
    Member since:
    Jan 2012

    Posted 24 Jan 2012 Link to this post

    Thanks! Using the MSI Installer with the link you provided worked!
  16. Jason Linden
    Jason Linden avatar
    9 posts
    Member since:
    Nov 2007

    Posted 24 Jan 2012 Link to this post

    Nice! I'm comforted a little bit that my team's own internal installs aren't the only installs being blocked by McAfee. It's been a massive pain for our software deployment folks...
  17. Scott
    Scott avatar
    1 posts
    Member since:
    Sep 2013

    Posted 19 Jun 2014 Link to this post

    2014/06/19 just did an update and Visual Studio 2013 Professional crashed and burned.
    basically it states No InprocServer32 registered for package [MRU Package] %windir%\system32\mscoree.dll

    I know the install package uninstalled a lot of things, cleaned and updated the registry and complied something before complete the install.

    <?xml version="1.0" encoding="utf-16"?>
    <?xml-stylesheet type="text/xsl" href="ActivityLog.xsl"?>
    <activity>
      <entry>
        <record>1</record>
        <time>2014/06/19 18:27:06.707</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Microsoft Visual Studio 2013 version: 12.0.30501.0</description>
      </entry>
      <entry>
        <record>2</record>
        <time>2014/06/19 18:27:06.707</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Running in User Groups: Administrators Users</description>
      </entry>
      <entry>
        <record>3</record>
        <time>2014/06/19 18:27:06.707</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Available Drive Space: C:\ drive has 763960193024 bytes; E:\ drive has 81579372544 bytes</description>
      </entry>
      <entry>
        <record>4</record>
        <time>2014/06/19 18:27:06.708</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Internet Explorer Version: 10.0.9200.16921</description>
      </entry>
      <entry>
        <record>5</record>
        <time>2014/06/19 18:27:06.708</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>.NET Framework Version: 4.0.40305.0</description>
      </entry>
      <entry>
        <record>6</record>
        <time>2014/06/19 18:27:06.709</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>MSXML Version: 6.30.7601.18431</description>
      </entry>
      <entry>
        <record>7</record>
        <time>2014/06/19 18:27:06.839</time>
        <type>Information</type>
        <source>Microsoft Visual Studio Appid Stub</source>
        <description>Application launch on system with DPI X/Y: 96/96</description>
      </entry>
      <entry>
        <record>8</record>
        <time>2014/06/19 18:27:07.452</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Entering function CVsPackageInfo::HrInstantiatePackage</description>
        <guid>{00CD9DDA-7350-457C-A240-71BD667FC4DE}</guid>
      </entry>
      <entry>
        <record>9</record>
        <time>2014/06/19 18:27:07.452</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Begin package load [Task Scheduler Package]</description>
        <guid>{00CD9DDA-7350-457C-A240-71BD667FC4DE}</guid>
      </entry>
      <entry>
        <record>10</record>
        <time>2014/06/19 18:27:07.551</time>
        <type>Information</type>
        <source>Package Framework</source>
        <description>Initialized ServiceProvider.GlobalProvider from SetSite.</description>
      </entry>
      <entry>
        <record>11</record>
        <time>2014/06/19 18:27:07.598</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>End package load [Task Scheduler Package]</description>
        <guid>{00CD9DDA-7350-457C-A240-71BD667FC4DE}</guid>
      </entry>
      <entry>
        <record>12</record>
        <time>2014/06/19 18:27:07.657</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Entering function CVsPackageInfo::HrInstantiatePackage</description>
        <guid>{5E56B3DB-7964-4588-8D49-D3523AB7BDB9}</guid>
      </entry>
      <entry>
        <record>13</record>
        <time>2014/06/19 18:27:07.657</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Begin package load [Environment Package Window Management]</description>
        <guid>{5E56B3DB-7964-4588-8D49-D3523AB7BDB9}</guid>
      </entry>
      <entry>
        <record>14</record>
        <time>2014/06/19 18:27:07.838</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>End package load [Environment Package Window Management]</description>
        <guid>{5E56B3DB-7964-4588-8D49-D3523AB7BDB9}</guid>
      </entry>
      <entry>
        <record>15</record>
        <time>2014/06/19 18:27:07.892</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Entering function CVsPackageInfo::HrInstantiatePackage</description>
        <guid>{2DC9DAA9-7F2D-11D2-9BFC-00C04F9901D1}</guid>
      </entry>
      <entry>
        <record>16</record>
        <time>2014/06/19 18:27:07.893</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Begin package load [Visual Studio Logging Package]</description>
        <guid>{2DC9DAA9-7F2D-11D2-9BFC-00C04F9901D1}</guid>
      </entry>
      <entry>
        <record>17</record>
        <time>2014/06/19 18:27:07.893</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Loading UI library</description>
        <guid>{2DC9DAA9-7F2D-11D2-9BFC-00C04F9901D1}</guid>
        <path>C:\Program Files (x86)\Microsoft Visual Studio 12.0\\Common7\IDE*\VsLogUI.dll</path>
      </entry>
      <entry>
        <record>18</record>
        <time>2014/06/19 18:27:07.916</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>End package load [Visual Studio Logging Package]</description>
        <guid>{2DC9DAA9-7F2D-11D2-9BFC-00C04F9901D1}</guid>
      </entry>
      <entry>
        <record>19</record>
        <time>2014/06/19 18:27:08.823</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Entering function CVsPackageInfo::HrInstantiatePackage</description>
        <guid>{F384B236-B4A9-401B-BC58-3106E3ACA3EC}</guid>
      </entry>
      <entry>
        <record>20</record>
        <time>2014/06/19 18:27:08.823</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Begin package load [Shell Common UI Package]</description>
        <guid>{F384B236-B4A9-401B-BC58-3106E3ACA3EC}</guid>
      </entry>
      <entry>
        <record>21</record>
        <time>2014/06/19 18:27:08.853</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>End package load [Shell Common UI Package]</description>
        <guid>{F384B236-B4A9-401B-BC58-3106E3ACA3EC}</guid>
      </entry>
      <entry>
        <record>22</record>
        <time>2014/06/19 18:27:09.043</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Entering function CVsPackageInfo::HrInstantiatePackage</description>
        <guid>{8FF5C2A8-5EBA-4717-8EE1-46B6427D8FF3}</guid>
      </entry>
      <entry>
        <record>23</record>
        <time>2014/06/19 18:27:09.053</time>
        <type>Error</type>
        <source>VisualStudio</source>
        <description>No InprocServer32 registered for package [MRU Package]</description>
        <guid>{8FF5C2A8-5EBA-4717-8EE1-46B6427D8FF3}</guid>
        <hr>8007007e</hr>
        <errorinfo>Class not registered.
    Looking for object with CLSID: {6C4024E7-5DEC-4EEC-B3F9-55B3F3AD1E9E}.</errorinfo>
        <path>%windir%\system32\mscoree.dll</path>
      </entry>
      <entry>
        <record>24</record>
        <time>2014/06/19 18:27:09.064</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Entering function VBDispatch::GetTypeLib</description>
      </entry>
      <entry>
        <record>25</record>
        <time>2014/06/19 18:27:09.064</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Entering function LoadDTETypeLib</description>
      </entry>
      <entry>
        <record>26</record>
        <time>2014/06/19 18:27:09.149</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Leaving function LoadDTETypeLib</description>
      </entry>
      <entry>
        <record>27</record>
        <time>2014/06/19 18:27:09.149</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Leaving function VBDispatch::GetTypeLib</description>
        <guid>{80CC9F66-E7D8-4DDD-85B6-D9E6CD0E93E2}</guid>
      </entry>
      <entry>
        <record>28</record>
        <time>2014/06/19 18:27:09.149</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Entering function VBDispatch::GetTypeLib</description>
      </entry>
      <entry>
        <record>29</record>
        <time>2014/06/19 18:27:09.152</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Leaving function VBDispatch::GetTypeLib</description>
        <guid>{18BEB7F2-CA98-11D1-B6E7-00A0C90F2744}</guid>
      </entry>
      <entry>
        <record>30</record>
        <time>2014/06/19 18:27:09.152</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Entering function VBDispatch::GetTypeLib</description>
      </entry>
      <entry>
        <record>31</record>
        <time>2014/06/19 18:27:09.152</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Leaving function VBDispatch::GetTypeLib</description>
        <guid>{80CC9F66-E7D8-4DDD-85B6-D9E6CD0E93E2}</guid>
      </entry>
      <entry>
        <record>32</record>
        <time>2014/06/19 18:27:09.152</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Entering function VBDispatch::GetTypeLib</description>
      </entry>
      <entry>
        <record>33</record>
        <time>2014/06/19 18:27:09.152</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Leaving function VBDispatch::GetTypeLib</description>
        <guid>{80CC9F66-E7D8-4DDD-85B6-D9E6CD0E93E2}</guid>
      </entry>
      <entry>
        <record>34</record>
        <time>2014/06/19 18:27:09.259</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Entering function VBDispatch::GetTypeLib</description>
      </entry>
      <entry>
        <record>35</record>
        <time>2014/06/19 18:27:09.259</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Leaving function VBDispatch::GetTypeLib</description>
        <guid>{80CC9F66-E7D8-4DDD-85B6-D9E6CD0E93E2}</guid>
      </entry>
    </activity>

  18. Dyanko
    Admin
    Dyanko avatar
    122 posts

    Posted 24 Jun 2014 Link to this post

    Hi Scott,

    Thank you for contacting us.

    We recommend to avoid posting the same question multiple times, in order not to split information between threads and handle your question more precisely. If it is an emergency use our support ticketing system (http://www.telerik.com/account/support-tickets/available-support-list.aspx) as this is the best way to reach our support staff - the support system assigns a response time for all of your questions, depending on your license and ensures that all questions will reach the respective developers, if needed.
    You can post your questions in the forums when you don't need an urgent answer and you want to help the community as well.


    As for the ticket with ID #831452, we provided an answer to your inquiry on 23-Jun-2014.

    Please let us know if your issue is resolved and if any further assistance is needed.

    Regards,
    Dyanko
    Telerik
     
    OpenAccess ORM is now Telerik Data Access. For more information on the new names, please, check out the Telerik Product Map.
     
Back to Top
DevCraft banner