Installation / Download Error

6 posts, 0 answers
  1. Pete
    Pete avatar
    3 posts
    Member since:
    Feb 2014

    Posted 24 Feb 2014 Link to this post

    I am trying to instatall the Telerik Trial Platform and have selected only VS 2012 options.

    I get the following error when it begins the download process (still at 0MB).
    System.ArgumentNullException: Value cannot be null.
    Parameter name: input

    Server stack trace: 
       at System.Version.Parse(String input)
       at System.Version..ctor(String version)
       at Telerik.CommonInstaller.DataModels.MsiInstallerInfo.get_Version()
       at Telerik.CommonInstaller.Application.Helpers.RelatedInstallerDetector.MsiInstallerInfoExtensions.GetRelation(IMsiInstallerInfo originalInstaller, IMsiInstallerInfo installer)
       at Telerik.CommonInstaller.Application.Helpers.RelatedInstallerDetector.RelatedInstallationsDetector.<>c__DisplayClass1.<GetRelatedInstallations>b__0(IMsiInstallerInfo p)
       at System.Linq.Enumerable.WhereSelectArrayIterator`2.MoveNext()
       at System.Linq.Buffer`1..ctor(IEnumerable`1 source)
       at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source)
       at Telerik.CommonInstaller.Application.Helpers.RelatedInstallerDetector.RelatedInstallationsDetector.GetRelatedInstallations(IMsiInstallerInfo installer)
       at Telerik.CommonInstaller.Application.ProductInstaller.<GetUpgradeOperations>d__2d.MoveNext()
       at System.Collections.Generic.List`1.InsertRange(Int32 index, IEnumerable`1 collection)
       at Telerik.CommonInstaller.Application.ProductInstaller.GetProductVersionInstallOperations(IInstallable product)
       at Telerik.CommonInstaller.Application.ProductInstaller.InstallProduct(IInstallable product)
       at Telerik.CommonInstaller.Application.Actions.InstallAction.GetSequenceCookie()
       at Telerik.CommonInstaller.Application.Actions.InstallActionBase.Initialize()
       at Telerik.CommonInstaller.Application.Services.InstallationService.TrackAndStartActions(IList`1 actions)
       at Telerik.CommonInstaller.Application.Services.InstallationService.StartActions(IList`1 actions)
       at Telerik.CommonInstaller.InstallerUIBase.ViewModels.InstallationProgressPageViewModelBase.<OnNavigated>b__12()
       at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
       at System.Runtime.Remoting.Messaging.StackBuilderSink.AsyncProcessMessage(IMessage msg, IMessageSink replySink)

    Exception rethrown at [0]: 
       at System.Runtime.Remoting.Proxies.RealProxy.EndInvokeHelper(Message reqMsg, Boolean bProxyCase)
       at System.Runtime.Remoting.Proxies.RemotingProxy.Invoke(Object NotUsed, MessageData& msgData)
       at System.Action.EndInvoke(IAsyncResult result)
       at Telerik.CommonInstaller.InstallerUIBase.ViewModels.InstallationProgressPageViewModelBase.<>c__DisplayClass16.<>c__DisplayClass19.<OnNavigated>b__15()
       at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
       at MS.Internal.Threading.ExceptionFilterHelper.TryCatchWhen(Object source, Delegate method, Object args, Int32 numArgs, Delegate catchHandler)
  2. Vesko
    Admin
    Vesko avatar
    97 posts

    Posted 25 Feb 2014 Link to this post

    Hello Pete,

    We are sorry for the inconvenience.

    Is this one time error? Could you give the application another try?

    Regards,
    Vesko
    Telerik
  3. Pete
    Pete avatar
    3 posts
    Member since:
    Feb 2014

    Posted 25 Feb 2014 in reply to Vesko Link to this post

    It happens every time I run the installer. It happens when I use the default options and when I select only VS 2012 options.

    I am running Windows 64-bit if that helps.
  4. Vesko
    Admin
    Vesko avatar
    97 posts

    Posted 26 Feb 2014 Link to this post

    Hi Pete,

    What is the exact product you are trying to install? This may help us to locate the problem. Meanwhile you could try our download page (LINK).


    Regards,
    Vesko
    Telerik
  5. Pete
    Pete avatar
    3 posts
    Member since:
    Feb 2014

    Posted 04 Mar 2014 in reply to Vesko Link to this post

    I have tried installing: both DevCraftUltimateSetup_2014_1_210.exe and Telerik_UI_for_ASP.NET_AJAX_Setup_2013_3_1324.exe and have gotten the same error. I am installing to C:\Program Files (x86)\Telerik with the Telerick Control Panel.

    I again tried to install DevCraft Ultimate with these options selected for Visual Studio 2012 Support ONLY:
    UI for ASP.NET AJAX, JustMock, UI for WPF, JustCode, Testing Framework, JustTrace, Data Access, (Customer Experience Improvement Program).
    All progress windows stay at 0 and the error displays in an Error Report window. I click the send button each time and the installation quits.





  6. Vesko
    Admin
    Vesko avatar
    97 posts

    Posted 06 Mar 2014 Link to this post

    Hello Pete,

    We haven't met this problem before and we are not able to reproduce it. Is peter_cuiry@ca11.uscourts.gov the email you log into the web installer with? We didn't receive any error logs from this email. If not - what email do you use? This information may help us to resolve that issue. Meanwhile you could try to install the products one by one to find out which one causes the issue. You could also run DevCraftUltimateSetup_2014_1_210.exe and make a fresh registration with new email (you are able to register through the installer).

    Regards,
    Vesko
    Telerik

    DevCraft Q1'14 is here! Join the free online conference to see how this release solves your top-5 .NET challenges. Reserve your seat now!

Back to Top