Install Failure

22 posts, 0 answers
  1. John Berlo
    John Berlo avatar
    8 posts
    Member since:
    Oct 2007

    Posted 27 Apr 2011 Link to this post

    MSI (s) (8C:04) [11:24:46:458]: Note: 1: 2262 2: Error 3: -2147287038
    Error 1402. Could not open key: HKEY_LOCAL_MACHINE32\Software\Wow6432Node\Classes\CLSID\{8A684259-AD8E-4C84-B319-00EF337879FF}\LocalServer32.  System error 161.  Verify that you have sufficient access to that key, or contact your support personnel.
    MSI (s) (8C:04) [11:24:48:349]: Note: 1: 2262 2: Error 3: -2147287038
    MSI (s) (8C:04) [11:24:48:349]: Product: Telerik JustTrace Beta -- Error 1402. Could not open key: HKEY_LOCAL_MACHINE32\Software\Wow6432Node\Classes\CLSID\{8A684259-AD8E-4C84-B319-00EF337879FF}\LocalServer32.  System error 161.  Verify that you have sufficient access to that key, or contact your support personnel.

    I'm running Windows Server 2008R2 64-bit  I'm a local admin.

    Thanks,
    ---John
  2. John Berlo
    John Berlo avatar
    8 posts
    Member since:
    Oct 2007

    Posted 27 Apr 2011 Link to this post

    And no, running in an administrator window does not get past the error.
    Running with the /a switch just brings up the install window with the only button available Finish.
  3. DevCraft banner
  4. Adrian Pickering
    Adrian Pickering avatar
    4 posts
    Member since:
    Jan 2009

    Posted 27 Apr 2011 Link to this post

    For anyone else having problems with UAC when trying to install, try this:
    Open a command line prompt in administrator mode
    >justtracebeta_trial.msi

    Hope this helps some people.
  5. John Berlo
    John Berlo avatar
    8 posts
    Member since:
    Oct 2007

    Posted 27 Apr 2011 Link to this post

    Running in a command window in Administrator mode: failure

    Oh, and UAC is not turned on.
  6. Todd Anglin
    Todd Anglin avatar
    2040 posts
    Member since:
    Aug 2005

    Posted 27 Apr 2011 Link to this post

    Hello John-

    Thanks for reporting the issue. Sorry to hear that the existing workaround is not working for you scenario. We will investigate the installer in this environment and make sure runs correctly. Apologies for the beta installer issues.

    The product team will review this shortly and provide a resolution ASAP.

    -Todd
  7. Thomas Van den Bossche
    Thomas Van den Bossche avatar
    1 posts
    Member since:
    Dec 2009

    Posted 27 Apr 2011 Link to this post

    Having the some problem and starting it from command prompt with the /a switch also didn't work.
    Tested it on two computers (both Windows 7 Professional).
  8. Todd Anglin
    Todd Anglin avatar
    2040 posts
    Member since:
    Aug 2005

    Posted 27 Apr 2011 Link to this post

    Interesting. We'll definitely start investigating more scenarios to improve the post-Beta installer.

    Please make sure .NET 4.0 is installed on your system, too. That may be a contributing factor if you're having problems installing JustTrace.

    Thanks again to everyone for sharing the early beta feedback/installer experiences.

    -Todd
  9. Eric Moore
    Eric Moore avatar
    25 posts
    Member since:
    Mar 2010

    Posted 27 Apr 2011 Link to this post

    Running in a command window as admin worked for me! Thanks!
  10. Vladi
    Admin
    Vladi avatar
    167 posts

    Posted 29 Apr 2011 Link to this post

    Hi all,

    Thank you all for your feedback. It is very valuable to us and we intend on acting upon it. As a proof please try our first internal build which mainly addresses the installation process and improves it. You could download it from this link.

    Hopefully you won't have installation troubles anymore, but if you do, please let us know.
     

    All the best,
    Vladi
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>

  11. JT
    JT avatar
    49 posts
    Member since:
    Mar 2007

    Posted 05 May 2011 Link to this post

    I just wanted to confirm that the /a switch doesn't work, running it from a cmd window started as an administration did not work, and installing the latest internal build under the local administrator account did not work. I still cannot get past the error regarding a missing registry key starting with HKEY_LOCAL_MACHINE32.
  12. Dwight
    Admin
    Dwight avatar
    475 posts

    Posted 11 May 2011 Link to this post

    Hello Justin,

    The issue is resolved. Expect the next internal build.

    Best,
    Dwight
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>

  13. JT
    JT avatar
    49 posts
    Member since:
    Mar 2007

    Posted 11 May 2011 Link to this post

    Awesome, thanks Dwight (and team)!
  14. Dwight
    Admin
    Dwight avatar
    475 posts

    Posted 12 May 2011 Link to this post

    You are welcome :)

    All the best,
    Dwight
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>

  15. Chris
    Chris avatar
    8 posts
    Member since:
    Nov 2010

    Posted 13 May 2011 Link to this post

    Any idea on when we can expect that internal build? I'm pretty eager to try it out. :)
  16. Mihail
    Admin
    Mihail avatar
    75 posts

    Posted 13 May 2011 Link to this post

    Hi Chris,

    We plan to release an internal build next week. You should not expect an internal build each week though. Our goal is to release two or three more internal builds because the community feedback so far was very valuable. Stay tuned.

    Best wishes,
    Mike
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>

  17. Vladi
    Admin
    Vladi avatar
    167 posts

    Posted 30 May 2011 Link to this post

    Hello Everyone,

     
    We have just released our new Beta version. Please try it and let us know about any issue you may encounter. We've also introduced auto update manager in JustTrace. So from now you will get automatic notification for any new version we release.

    Kind regards,
    Vladi
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>

  18. Chris
    Chris avatar
    8 posts
    Member since:
    Nov 2010

    Posted 30 May 2011 Link to this post

    I'm still unable to install. I updated my existing ticket with the new log file.
  19. Jakkie Esschert van den
    Jakkie Esschert van den avatar
    61 posts
    Member since:
    Sep 2009

    Posted 31 May 2011 Link to this post

    I'm also unable to install the latest version, although I never had an issue with the first release. I'm running the installer on Windows 7 Pro 32bit. I didn't remove the original installation before installing.

    The relevant part of the log seems to be:

    MSI (s) (20:54) [09:41:20:782]: Hello, I'm your 32bit Elevated custom action server.
    SFXCA: Extracting custom action to temporary directory: C:\windows\Installer\MSI4302.tmp-\
    SFXCA: Binding to CLR version v2.0.50727
    Calling custom action InstallerCustomCommands!InstallerCustomCommands.CustomActions.AddUserToPerformanceGroup
    Kan de groepsnaam niet vinden
       bij InstallerCustomCommands.CustomActions.NetLocalGroupAddMember(String groupName, String userName)
       bij InstallerCustomCommands.CustomActions.AddUserToPerformanceGroup(Session session)
    CustomAction AddUserToPerformanceGroup returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
    Action ended 9:41:22: InstallFinalize. Return value 3.

  20. Todor
    Admin
    Todor avatar
    63 posts

    Posted 31 May 2011 Link to this post

    Hi Jakkie,

    Thank you for reporting the problem.

    It will be very helpful if you send us the entire log file, as it contains details which can help us to reproduce the problem on our side.

    Greetings,
    Todor
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>

  21. Jakkie Esschert van den
    Jakkie Esschert van den avatar
    61 posts
    Member since:
    Sep 2009

    Posted 31 May 2011 Link to this post

    I've uploaded it here: http://d6.nl/stuff/JustTraceBeta_2011.1.530_DEV.msi.log.zip
  22. Todor
    Admin
    Todor avatar
    63 posts

    Posted 31 May 2011 Link to this post

    Hello Jakkie,

     We got the log file, thank you! Hopefully we will be able to fix the issue for the next public release.

    Kind regards,
    Todor
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>

  23. Todor
    Admin
    Todor avatar
    63 posts

    Posted 31 May 2011 Link to this post

    Hi Chris,

     
    We suggest you to temporarily disable your HIPS while installing JustTrace. Thanks for helping us understanding the issue.

    All the best,
    Todor
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>

Back to Top
DevCraft banner