InitialPath - Invalid characters in folder name.

3 posts, 1 answers
  1. KAB
    KAB avatar
    14 posts
    Member since:
    Aug 2010

    Posted 25 Sep 2010 Link to this post

    Code FileExplorer.InitialPath = "~/Documents";  or on any folder throws message box "Invalid characters in folder name."
    This bug was introduced in Telerik.Web.UI_2010_2_826 and later. All previous releases until was all right in such a functionality.
    Check it, please.

    Resolution has been found. Thanks.

    How to delete this post?
  2. Answer
    Dobromir avatar
    1633 posts

    Posted 29 Sep 2010 Link to this post


    Actually this is not a bug but a designed behavior. InitialPath property expects physical path as value, and the "~/FolderName" is a virtual path - the ~ (tilde) is invalid character for folder / file names.

    Setting virtual path to the InitialPath property was possible in the previous versions due to a bug in RadFileExplorer.

    Best wishes,
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. DevCraft R3 2016 release webinar banner
  4. Ashwin Shriwas
    Ashwin Shriwas avatar
    1 posts
    Member since:
    Apr 2006

    Posted 18 Apr in reply to Dobromir Link to this post

     My ImageManager path is given below:

    string[] viewPath = new string[] { @"~/SchemeImage/" + (!string.IsNullOrEmpty(Request.QueryString["CorporateSchemeID"]) ? Convert.ToString(Request.QueryString["CorporateSchemeID"]) : "") };

    It generates the path : ~/SchemeImage/478

    When I select Image in RADEditor and click on ImageManager Icon it gives me error "Invalid Characters in folder name". I am guessing due to tilde (~) sysmbol it is throwing this error. Please help to resolve this issue.

    Note: SchemeImage is virtual directory in IIS which is pointing to different server.

Back to Top