Images uploaded with Image Manager do not get IUSR permissons

3 posts, 0 answers
  1. Sam
    Sam avatar
    2 posts
    Member since:
    Dec 2015

    Posted 03 Dec 2015 Link to this post


    I have recently upgraded from using CuteEditor to RadEditor but am having an issue with the FileExplorer functionality.

    There is one site (IIS 7.0) containing the Editor used for admin purposes, this points to a virtual directory to save images in the /uploads folder of the main site (also IIS 7.0).

    Images can be saved, renamed and deleted perfectly however when they are saved none of them have the standard IUSR user and permissions (even though it is on the parent folder) resulting in a 401 error every time the main site tries to view the uploaded image.

    Why are the files not being saved with the parent folders permissions and how can I set it to that it saves them in a way that is viewable by the main site?
  2. Vessy
    Vessy avatar
    1350 posts

    Posted 07 Dec 2015 Link to this post

    Hi Sam,

    We are not aware of the reported problem and I was not able to reproduce it on my side. Can you provide a little more details on the exact scenario in which you are using RadFileExplorer?
    Please, note that RadFileExplorer does not have a built in impersonation and its permissions are set only depending on the paths given to the ViewPaths, UploadPaths and DeletePaths properties, as all of the passed paths must be accessible for the application/current. I would advice that you try to create a file following this general approach and see whether its permissions will be set successfully.

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. DevCraft R3 2016 release webinar banner
  4. Sam
    Sam avatar
    2 posts
    Member since:
    Dec 2015

    Posted 23 Dec 2015 in reply to Vessy Link to this post

    I thought the image would get saved with permissions of the folder it is getting saved to however this was not the case. Adding the user and permissions to the folders containing the solution that uploads the files files solved the issue.

    Thank you for your help.

Back to Top