IIS6 or IIS7 with IIS6 Metabase Compatibility Required

10 posts, 0 answers
  1. Vladimir Tanasiev
    Vladimir Tanasiev avatar
    2 posts
    Member since:
    Sep 2009

    Posted 17 Apr 2010 Link to this post

    I have installed full version of VS2010 on my computer an i also have silverlight, sql exprees 2008 and i get next error.
    IIS6 or IIS7 with IIS6 Metabase Compatibility Required, but i checked and i have IIS7 instaled on my machine. Does any one know why i get this error or how do i fix ? What do i have to download in this context to make this program to work ?
  2. Vladimir Tanasiev
    Vladimir Tanasiev avatar
    2 posts
    Member since:
    Sep 2009

    Posted 17 Apr 2010 Link to this post

    I found the answer.
  3. David Harris
    Admin
    David Harris avatar
    1 posts

    Posted 19 Apr 2010 Link to this post

    Hello Vladimir Tanasiev,

    Section 2.1.2 of the TeamPulse help document (http://www.telerik.com/documents/team-productivity-tools/TeamPulseHelp.pdf) describes how to install the IIS Metabase and IIS 6 configuration compatability features within IIS 7. Is this what solved your problem? This may be helpful information for others with similar issues.

    Best wishes,
    David Harris
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  4. Tomer Zisman
    Tomer Zisman avatar
    3 posts
    Member since:
    Dec 2009

    Posted 21 Apr 2010 Link to this post

    Hi,

    I had the same problem but installing the IIS Metabase and IIS 6 configuration compatability features within IIS 7 did not resolve the problem. I still get the same notification.

    I have windows Vista.

    Any suggestions?
  5. David Harris
    Admin
    David Harris avatar
    1 posts

    Posted 21 Apr 2010 Link to this post

    Hello Tomer,

    So am I correct in understanding that you are receiving a message from the TeamPulse installer indicating that you must install the IIS 6 compatibility and metabase components, and yet you have already installed them so that your IIS 6 Management Compatibility tree within the Windows Features 'applet' looks the same as the screenshot on page 5 of the TeamPulse help document (http://www.telerik.com/documents/team-productivity-tools/TeamPulseHelp.pdf)?

    If so, do you mind posting the exact text of the installer message, and perhaps mind checking your Event Log for any relevant information coming from the installer?

    Thanks,
    David Harris
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  6. Marcus
    Marcus avatar
    15 posts
    Member since:
    Dec 2007

    Posted 22 Apr 2010 Link to this post

    Hi there,

    I'm getting the same problem as described here. However, to add the IIS metabase compatibility I have to add via the "Add Role Services" option in the Server Manager. The screens as described in the documentation linked above are not the same as what I see.
    This is Windows 2008 Server by the way. Is there perhaps something additional to install or does the changed setup come with one of the other pre-requistites like .NET framework 4.0?

    Thanks,

    Marcus
  7. David Harris
    Admin
    David Harris avatar
    1 posts

    Posted 22 Apr 2010 Link to this post

    Hi Marcus & Tomer,

    It appears this is an issue when running the installer on Vista or Win Server 2008 64 bit, where the 32bit registry hive did not have complete info about the installation component. This issue has been resolved internally in the latest installer bits, but as a workaround you can run an eleveated command prompt and type the following command:

    msiexec /i <installerPath> IIS6COMPAITABILITYMODE=#1  /l*v c:\teapulselog.txt

    Hopefully this will resolve the issue for you both.

    Regards,
    David Harris
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  8. Tomer Zisman
    Tomer Zisman avatar
    3 posts
    Member since:
    Dec 2009

    Posted 25 Apr 2010 Link to this post

    Hi David,

    Thanks, it resolved the IIS6 issue.
    Now I'm having another issue I get the attached error ("TeamPulse requires SQL Server 2008 to be installed") although it is already installed.

    LMK If you need me to submit the log created by the command line.

    Thanks,
    Tomer.
  9. Ryan
    Admin
    Ryan avatar
    164 posts

    Posted 26 Apr 2010 Link to this post

    Hi Tomer Zisman,

    TeamPulse installer looks for an SQL Server Express instance named sqlexpress on the local machine. Can you confirm that your SQL Express install instance is using that name?

    Thanks,
    Ryan
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  10. Tomer Zisman
    Tomer Zisman avatar
    3 posts
    Member since:
    Dec 2009

    Posted 27 Apr 2010 Link to this post

    Thanks! that was it.
Back to Top