IE9 Ignoring Style Sheet

3 posts, 0 answers
  1. Kei
    Kei avatar
    2 posts
    Member since:
    Mar 2012

    Posted 01 Mar 2012 Link to this post

    IE9 seems to be ignoring the style sheets from RadStyleSheet for a custom skin if it is not running in compatibility mode. I have a custom skin from the Visual Style Builder that I made into an assembly and added as a DLL to my website. I tested it on a sample page and this is the error that IE gives me:

    SEC7113: CSS was ignored due to mime type mismatch
    Telerik.Web.UI.WebResource.axd?compress=1&_TSM_CombinedScripts_=%3b%3bMySkin%3aen-US%3a759be785-708d-4ffb-9221-0edb1548ff41%3a7d6cac8e%3bTelerik.Web.UI%2c+Version%3d2012.1.215.40%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3ab29b07e8-2c1e-44e5-9e1b-59bb6459fb01%3afe53831e

    I'd prefer to keep away from compatibility mode. Thanks for the help.
  2. Kit Cat
    Kit Cat  avatar
    8 posts
    Member since:
    Oct 2010

    Posted 06 Mar 2012 Link to this post

    Hi Kei,

    You can disable your compatibility mode as described in these forum posts:

    http://ceeyel.com/css/disable-ie8-compatibility-mode.html
    http://stackoverflow.com/questions/3803901/how-can-i-programmaticaly-disable-ie-compatibility-mode
    http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Kei
    Kei avatar
    2 posts
    Member since:
    Mar 2012

    Posted 06 Mar 2012 Link to this post

    I'd rather not use compatibility mode. Turns out you need to reference the CSS in the AssemblyInfo.cs file in addition to one used to create the assembly.
Back to Top