IE non-responsive when recording

5 posts, 0 answers
  1. Su
    Su avatar
    1 posts
    Member since:
    Oct 2015

    Posted 26 Oct 2015 Link to this post


    I am new to Telerik and have downloaded a trial version.  I am trying to record a simple script against IE11 on Windows 8.  Whenever I click on Highlight Elements IE becomes non-responsive.

    I have attempted the same recording in Chrome and whilst that records successfully the website in question behaves slightly differently on Chrome and the execution on IE of the Chrome recorded script is failing.

    Bearing in mind I am new to this tool does anyone have any suggestions?




  2. Cody
    Cody avatar
    3360 posts

    Posted 27 Oct 2015 Link to this post

    Hi Su,

    Thank you for taking the time to evaluate Test Studio for your test automation needs.

    I am sorry you are running into this problem. I can confirm that Test Studio supports IE 11 and Windows 8. The problem you describe is completely unexpected and abnormal behavior. There are no settings I can suggest to overcome this particular problem. Are you able to try a different machine, such as IE 10 on a Windows 7 machine? I am wondering if this problem is somehow OS specific or browser version specific.

    Since this is a problem with recording I'd like to try and reproduce the problem on my machine so that I can investigate what may be causing it. Is there a publicly accessible URL I can connect to from my machine? Can you give me steps to follow to reproduce this problem?

    I look forward to hearing back from you.

    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
  3. SHK
    SHK avatar
    11 posts
    Member since:
    Jul 2015

    Posted 02 Nov 2015 Link to this post

    Hi ,

     I see the similar problem with IE 11 on Windows 10. I faced it sometimes earlier also but these days it is way too often. And today it happens every time I try to highlight. Is there any solution to this? I tried restarting my machine a couple of times, tried deleting cookies etc. assuming it might be a browser or system issue. But I don't think it is as no matter what I do the IE gets unresponsive when 'highlight' is used.


    Sprithi H K

  4. Chad
    Chad avatar
    24 posts
    Member since:
    Mar 2015

    Posted 02 Nov 2015 in reply to SHK Link to this post

    I've experienced similar issues with IE 11, but under windows 8.1 and mainly only when trying to highlight drop down lists.  IE will just freeze and I have to end task on IE to get things going again.  Not ideal, but my solution thus far has been to just record with FireFox and only record with IE when I ​want to use the additional quick steps that are only available in IE (or when I know I won't need to look at any drop down lists).  So far this hasn't been any kind of deal-breaker for us.

    It's good to know I'm not the only one that has experienced this type of problem with IE.  The quick step features are really nice and easy to use which opens up our test creation to folks that aren't all crazy about coding.  I'll be watching this thread in hopes there might be some suggestions or resolution forthcoming.

  5. Ivaylo
    Ivaylo avatar
    749 posts

    Posted 05 Nov 2015 Link to this post

    Hello all,

    I am sorry to hear you are experiencing these problems. Unfortunately as Cody stated and requested we will need somehow to reproduce this behavior and investigate it further. Also usually such problems are environment specific, you can reproduce it on machine and not reproduce it on another. I am also constantly using IE 11 as recording browser on Windows 8 and Windows 10 and I am not experiencing such problems.

    It would be nice if we can get a public accessible application that we can reproduce this behavior so we can log a bug and fix it.

    Unfortunately without a reliable repro we cannot do much more that provide standard approaches such as:
    1. Running Test Studio/IE as administrator. Also make sure the IE has no additional addons.
    2. Try running IE in No-Add-ons mode as shown in this article
    3. Make sure the display setting is set to 100%
    4.Turn off Firewall or Antivirus program, especially some antivirus programs may prevent us from proper injection into the IE
    5. Turn off any additional themes applied on Windows

    Thank you for your understanding.

    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
Back to Top