Icenium IOS7 menu is "bugging" on offline mode

4 posts, 0 answers
  1. André
    André avatar
    2 posts
    Member since:
    Jul 2013

    Posted 02 Jan 2014 Link to this post

    Hello every1, i´m needing so much a help.

    A create a Icenium App using Kendo template to ios7 but it´s getting a problem when it´s on off-line mode (cached mode) because the menu to select the pages is missing, it´s bugging and break the apps because i can´t change to any page na the app is "frozen" doesn´t go to nothing.

    Pls help me how to cache correctely the kendo/styles/kendo.mobile.all.min.css and the wp8_icons.png pls.

    Tks for help
  2. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 03 Jan 2014 Link to this post

    Hi André,

    We're not sure we understand the problem you experience. Please elaborate, does this problem occur in the simulator with Network Connection set to None or does it occur on real device that has no data connectivity? If the latter, are you testing on iOS or Android?

    All .js files present in the Kendo UI template are part of the app and are available for off-line usage as well. Windows Phone 8 support is coming to Icenium at the beginning of March, so WP8 specific files are not relevant at this time.

    Regards,
    Steve
    Telerik
    You've missed the Icenium Visual Studio Integration keynote? It has been recorded and posted here.
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
  3. Decco
    Decco avatar
    9 posts
    Member since:
    Aug 2013

    Posted 03 Jan 2014 Link to this post

    The problem is in the iphone 5. When i use the app into the iphone in offline mode the menu bugs like if the images of the menu (wp8_icons.png and the other image wp8... (I forget the name))  is not caching and in offline mode i can't change from the first (starter) page and i saw yestarday that in android the same prolem occur.

    i just need to know how to cache the wp8_icons.png and the kendo.mobile.all.min.css and this kast must get the image from the localhost not from kendoui webpage.
  4. Decco
    Decco avatar
    9 posts
    Member since:
    Aug 2013

    Posted 05 Jan 2014 Link to this post

    I solve the problem... I had deleted the images/kendoui.ttf and images/kendoui.woff and this made the app didn't work in offline mode. Then i upload back to my app's code and everything works greatly.

    tks for the help
Back to Top