Icenium Graphite Does not update styles in the simulator

10 posts, 0 answers
  1. Edward
    Edward avatar
    5 posts
    Member since:
    Oct 2012

    Posted 27 Mar 2013 Link to this post

    Icenium Graphite seems to be caching styles and does not update when reloading the simulator- It worked fine for some css changes, but after a while, stopped responding to my edits.
    I tested this out by commenting out the entire default kendo mobile stylesheet- it still loaded in the simulator, no problem.
  2. Jordan
    Admin
    Jordan avatar
    197 posts

    Posted 27 Mar 2013 Link to this post

    Hello again Edward,

    Can you reproduce this with a fresh Kendo project? 

    Kind regards,
    Jordan
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Pluralsight.
  3. Edward
    Edward avatar
    5 posts
    Member since:
    Oct 2012

    Posted 02 Apr 2013 Link to this post

    Since we haven't really gotten all that far with the original app, my boss told me to go ahead and just post this one.

    <sorry, boss asked me to remove the attachment>
  4. Max
    Max avatar
    11 posts
    Member since:
    Jan 2013

    Posted 02 Apr 2013 Link to this post

    I am having a similar issue. My javascript files are being cached. The only way for me to debug changes is to completely shutdown graphite.
  5. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 03 Apr 2013 Link to this post

    Hi guys,

    @Edward: thank you for the project, however we were not able to reproduce the problem on our end. Are there any specific steps involved prior running the simulator?

    @Max: can you provide us with a project as well? Does this happen on particular project or on any project in general? What if you modify one of our sample applications?

    Regards,
    Steve
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Kendo UI Dojo.
  6. Edward
    Edward avatar
    5 posts
    Member since:
    Oct 2012

    Posted 03 Apr 2013 Link to this post

    Negative, no special steps. I am running Icenium Graphite on both a virtual machine running Windows 7, and on the host machine using Windows 8, and have experienced the problem in both environments- the simulator will accept the edits for a while, but will after a short while cease to update, as if all css has been cached. Restarting Icenium does not fix this and will sometimes even result in loss of recent work. The only thing I have seen that will allow Icenium to start accepting changes again is to shut down the project, restart my machine, and begin again sometime later (like the next day)
  7. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 03 Apr 2013 Link to this post

    Hi Edward,

    When you say "after a short while", how long should we play around with it in order to be sure we're doing exactly as you do? What if you close Graphite and clear its Cache (C:\Users\<your_user>\AppData\Local\Telerik\BlackDragon\Cache) - does that make a difference?

    Can you try whether the same problem occurs in the Mist simulator?

    Regards,
    Steve
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Kendo UI Dojo.
  8. Max
    Max avatar
    11 posts
    Member since:
    Jan 2013

    Posted 03 Apr 2013 Link to this post

    To be more clear, my issue is with the webkit debugger built into the simulator. The simulator does seem to be updating with my changes. The files loaded into the actual debugger never update though.
  9. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 04 Apr 2013 Link to this post

    Hi Max,

    We've been contacted with reports about this weird behavior before, but have not been able to reproduce this in our local tests. Would you be so kind to provide us with exact steps to reproduce this in a new blank project. We need steps that always would exhibit the problem, so we can narrow it down.

    Thank you for the cooperation!

    All the best,
    Steve
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Kendo UI Dojo.
  10. Max
    Max avatar
    11 posts
    Member since:
    Jan 2013

    Posted 04 Apr 2013 Link to this post

    Happy to help Steve. Can't get to this right away, but I will as soon as I can.
Back to Top