Icenium Graphite crashes when opening any project

21 posts, 0 answers
  1. Richard
    Richard avatar
    24 posts
    Member since:
    May 2012

    Posted 19 Sep 2013 Link to this post

    Icenium Graphite suddenly crashed when opening any project. It started happening this morning around 10:00 AM. Now I can't do anything. I tried unstall/reinstall and it didn't work. Here is the problem details.

    Help please!

    Richard


    Problem signature:
      Problem Event Name: CLR20r3
      Problem Signature 01: icenium.graphite.exe
      Problem Signature 02: 2013.2.814.2
      Problem Signature 03: 520bcf56
      Problem Signature 04: mscorlib
      Problem Signature 05: 4.0.30319.19075
      Problem Signature 06: 515a73c2
      Problem Signature 07: 2b00
      Problem Signature 08: 0
      Problem Signature 09: 5O2O3I2ORVH4ZJ0NRQ1HQUEQ4B3YAU4U
      OS Version: 6.1.7601.2.1.0.256.4
      Locale ID: 1033
      Additional Information 1: 0a9e
      Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
      Additional Information 3: 0a9e
      Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

    Read our privacy statement online:
      http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

    If the online privacy statement is not available, please read our privacy statement offline:
      C:\Windows\system32\en-US\erofflps.txt

  2. Paul
    Paul avatar
    56 posts
    Member since:
    Jan 2006

    Posted 19 Sep 2013 Link to this post

    I too am experiencing this issue. I am getting a Visual Studio runtime error when launching any project. It was working fine all morning, until I restarted Graphite. I was present with some legal acceptance of terms and conditions and then the projects stopped working.

  3. Richard
    Richard avatar
    24 posts
    Member since:
    May 2012

    Posted 19 Sep 2013 Link to this post

    After cleared content of %localappdata%\Telerik\BlackDragon\Cache folder, it now crashes at the start-up. Here is the detail. It's happening to all PCs we have Icenium installed.


    Problem signature:
      Problem Event Name: CLR20r3
      Problem Signature 01: icenium.graphite.exe
      Problem Signature 02: 2013.2.814.2
      Problem Signature 03: 520bcf56
      Problem Signature 04: mscorlib
      Problem Signature 05: 4.0.30319.19075
      Problem Signature 06: 515a73c2
      Problem Signature 07: 2b00
      Problem Signature 08: 0
      Problem Signature 09: 5O2O3I2ORVH4ZJ0NRQ1HQUEQ4B3YAU4U
      OS Version: 6.1.7601.2.1.0.256.4
      Locale ID: 1033
      Additional Information 1: 0a9e
      Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
      Additional Information 3: 0a9e
      Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

    Read our privacy statement online:
      http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409
  4. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 19 Sep 2013 Link to this post

    Hi guys,

    We've released a new version an hour ago, but according to your logs, it's still trying to run the old version. It seems that your Graphite installation might be corrupted and you can try wiping it and installing from scratch:

    To wipe clean the Graphite installation:

    1. Close all Icenium Graphite instances. Open the Task Manager and make sure that there are no running processes with the name Icenium.Graphite.exe. If there is - kill it.
    2. Uninstall Graphite.
    3. Delete all contents in the %localappdata%\Temp\IceDeviceSimulator folder.
    4. Delete all contents in the  %localappdata%\Telerik\BlackDragon\ folder.
    5. Delete all contents in the  %localappdata%\Apps\2.0 folder.
    6. Re-install Graphite.
    Another possibility is if you have a caching device/proxy that returns the old application manifest. In this case, try downloading and starting the one attached to this thread.

    Regards,
    Steve
    Telerik

    Big news for mobile app and .NET developers! Hear about it at our Release Keynote. Thursday, September 26th, 11AM EDT
    Do you enjoy Icenium? Vote for it in Windows IT Pro Community Choice Awards as Best Cloud Computing Product or Service (Category 5).
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
  5. Richard
    Richard avatar
    24 posts
    Member since:
    May 2012

    Posted 19 Sep 2013 Link to this post

    Steve,
    Just tried everything but still the same error:


    Problem signature:
      Problem Event Name: CLR20r3
      Problem Signature 01: icenium.graphite.exe
      Problem Signature 02: 2013.2.814.2
      Problem Signature 03: 520bcf56
      Problem Signature 04: mscorlib
      Problem Signature 05: 4.0.30319.19075
      Problem Signature 06: 515a73c2
      Problem Signature 07: 2b00
      Problem Signature 08: 0
      Problem Signature 09: 5O2O3I2ORVH4ZJ0NRQ1HQUEQ4B3YAU4U
      OS Version: 6.1.7601.2.1.0.256.4
      Locale ID: 1033
      Additional Information 1: 0a9e
      Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
      Additional Information 3: 0a9e
      Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

    Read our privacy statement online:
      http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

    If the online privacy statement is not available, please read our privacy statement offline:
      C:\Windows\system32\en-US\erofflps.txt

  6. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 19 Sep 2013 Link to this post

    Hi Richard,

    Did you try the attached application manifest? If the problem persists, please run and save logs from FiddlerCap (with the Decrypt HTTPS Traffic option enabled). Start it prior Graphite and save the HTTP requests to disk. Save the sessions and attach it to this thread.

    Regards,
    Steve
    Telerik

    Big news for mobile app and .NET developers! Hear about it at our Release Keynote. Thursday, September 26th, 11AM EDT
    Do you enjoy Icenium? Vote for it in Windows IT Pro Community Choice Awards as Best Cloud Computing Product or Service (Category 5).
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
  7. Richard
    Richard avatar
    24 posts
    Member since:
    May 2012

    Posted 19 Sep 2013 Link to this post

    Steve,
    Yes I tried the attached application manifest.  I tried to attach the .saz file to the thread but it got rejected. I even tried to rename it to .gif, .txt but still no luck.

  8. Richard
    Richard avatar
    24 posts
    Member since:
    May 2012

    Posted 19 Sep 2013 Link to this post

    Steve,
    I managed to attached the zip file to my support ticket:

    http://www.telerik.com/account/support-tickets/view-ticket.aspx?threadid=738824
  9. Richard
    Richard avatar
    24 posts
    Member since:
    May 2012

    Posted 19 Sep 2013 Link to this post

    Any progress?
  10. Fernando
    Fernando avatar
    6 posts
    Member since:
    Aug 2013

    Posted 19 Sep 2013 Link to this post

    Waiting for news too...
  11. domiSchenk
    domiSchenk avatar
    55 posts
    Member since:
    Mar 2013

    Posted 20 Sep 2013 Link to this post

    have the same problem on my home machine. i found out if you are fast and open the log in graphite you see the error it throws.

    maybe the error is in the logs too: 
    %localappdata%\Telerik\BlackDragon\Logs
  12. Deyan Varchev
    Admin
    Deyan Varchev avatar
    150 posts

    Posted 20 Sep 2013 Link to this post

    Hello guys,

    Sorry for the slight delay. From the information Richard provided us it turns out he was not able to update Graphite correctly. Not sure if you all have the same problem. Here are the details we want you to try and give us info what happens:

    Can you verify that you can successfully download the following file:

    http://cdn.icenium.com/live/graphite/publish/Icenium.Graphite.application 

    After the download can you verify its contents - it should be a regular xml containing the following text:

    <assemblyIdentity name="Icenium.Graphite.application" version="2013.3.919.3"

    If you are able to download the file and its contents are fine, do the following:
    1. Start FiddlerCap (with the Decrypt HTTPS Traffic option enabled) . If there is some problems it will log valuable information.
    2. Uninstall Graphite from Control Panel\Programs\Programs and Features
    3. Double-click the downloaded .applicaiton file - this should start a new installation process. 

    If all goes well you should be able to successfully run Graphite.

    If you still aren't able to run Graphite - please send us back the FiddlerCap log plus the contents of your 
    %localappdata%\Telerik\BlackDragon\Logs folder.

    I hope this will help you solve the issue.Regards,
    Deyan Varchev
    Telerik

    Big news for mobile app and .NET developers! Hear about it at our Release Keynote. Thursday, September 26th, 11AM EDT
    Do you enjoy Icenium? Vote for it in Windows IT Pro Community Choice Awards as Best Cloud Computing Product or Service (Category 5).
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
  13. Fernando
    Fernando avatar
    6 posts
    Member since:
    Aug 2013

    Posted 20 Sep 2013 Link to this post

    It worked for me.

    Thank you!
  14. Richard
    Richard avatar
    24 posts
    Member since:
    May 2012

    Posted 20 Sep 2013 Link to this post

    This morning, when starting Icenium the upgrade was done automatically. After that, everything worked fine. Was there a new version/download pushed out last night?

    Either way, thanks for fixing the problem.

    Richard
  15. Gavin
    Gavin avatar
    4 posts
    Member since:
    Aug 2013

    Posted 27 Sep 2013 Link to this post

    Hi,

    I too am getting the evil crashing on load of a project. After uninstalling the software, the software will load the project but there is no navigator. Restarting the software seems to add 3 or 4 plugins the cache folder, but still no data navigator. That is until the 4th or so restart the software crashes.

    I've completed this process 3 or more times!

    Here is the exception, with the added detail of the internal loader exception:

    System.Reflection.ReflectionTypeLoadException was unhandled
      HResult=-2146232830
      Message=Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.
      Source=System.Reactive
      StackTrace:
           at System.Reactive.Concurrency.TaskPoolScheduler.<>c__DisplayClass2`1.<>c__DisplayClass4.<Schedule>b__1()
           at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
           at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
           at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
           at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
           at System.Threading.ThreadHelper.ThreadStart()
      InnerException: 


    LoaderExceptions:
    {"Could not load file or assembly 'Telerik.BlackDragon.Client.ProjectTypes.MSBuildCore, Version=2013.3.919.3, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.":"Telerik.BlackDragon.Client.ProjectTypes.MSBuildCore, Version=2013.3.919.3, Culture=neutral, PublicKeyToken=null"}

    I'll attach the msbuildcore  and the fiddlecap log - I couldn't attach the files as they're not an image or text, so I've base64 encoded them. :)

    Regards,
    Gav
  16. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 30 Sep 2013 Link to this post

    Hello Gav,

    We appreciate sending the exception and fiddler logs, but we did not become clear whether you have tried the suggestions of deleting the Graphite install folders. First try deleting all contents in the  %localappdata%\Telerik\BlackDragon\Cache folder and start Graphite again. If that doesn't help, try deleting all the files as noted in the post from 19 Sept.

    If still having problems, please try to disable firewall/antivirus or proxy configuration file (if using one) and try to install and run Graphite again.

    Regards,
    Steve
    Telerik
    You've missed the Icenium Visual Studio Integration keynote? It has been recorded and posted here.
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
  17. Gavin
    Gavin avatar
    4 posts
    Member since:
    Aug 2013

    Posted 30 Sep 2013 Link to this post

    Hi Steve,

    I had followed the procedure of uninstalling and deleting the cache folder, I don't use an anti virus or a proxy server and the firewall is the std Win7.

    I opened a project after a fresh install  but the IDE was missing the data navigator, I left the software open for a minute as I could see that plugins were populating the cache folder. 3 or 4 plugins came down and then nothing, so I restarted the software and some more plugins came down when I opened the project again, some plugs installed I waited a minute or so and still not data navigator, so I restarted Graphite again. After the 4th restart, opening the project crashed Graphite. 

    The reason I sent you the plugin was that I'd noticed it was smaller in size then previous version, I wasn't sure if the file was only part there and perhaps could have been a clue to problem?
     

    Regards,
    Gav
  18. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 01 Oct 2013 Link to this post

    Hello Gavin,

    Please zip and upload to a free file hosting the %localappdata%\Telerik\BlackDragon\Cache and %localappdata%\Telerik\BlackDragon\Logs folders, so we can review what has been downloaded so far and also see if there aren't any helpfup errors in the Graphite logs.

    Then as a second step, uninstall Graphite and delete the %localappdata%\Telerik\BlackDragon\Cache folder. Start FiddlerCap (with the Decrypt HTTPS Traffic option enabled) and install and run Graphite. Save the session log and upload it to a file hosting as well.

    Thank you for the cooperation!

    Regards,
    Steve
    Telerik
    You've missed the Icenium Visual Studio Integration keynote? It has been recorded and posted here.
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
  19. Gavin
    Gavin avatar
    4 posts
    Member since:
    Aug 2013

    Posted 02 Oct 2013 Link to this post

    Hey Steve,

    I fired up fiddler and reinstalled the software, this time it all worked. How annoying!

    Regards,
    Gav
  20. Gavin
    Gavin avatar
    4 posts
    Member since:
    Aug 2013

    Posted 10 Oct 2013 Link to this post

    Hey Steve,

    I went to use graphite this morning, the first time I've used it since I mentioned it was working and the first time I've tried to do development on it for quiet a while and the crash is back!

    I've uninstalled it, deleted the cache a log files and went through the install process again with FiddlerCap capturing data.

    Can you send me a direct email so that I can forward the log files on?



    Regards,
    Gav
  21. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 10 Oct 2013 Link to this post

    Hi Gavin,

    You could zip and upload the requested logs to a free file hosting and give us a link for download or send them to support at icenium com.

    Regards,
    Steve
    Telerik
    You've missed the Icenium Visual Studio Integration keynote? It has been recorded and posted here.
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
Back to Top