Icenium 1.9.1 - iOS Build in Mist: Exception: Unexpected server error

8 posts, 1 answers
  1. Answer
    Cedric
    Cedric avatar
    7 posts
    Member since:
    Jul 2013

    Posted 13 Nov 2013 Link to this post

    UPDATE: I just created a new project from scratch and it worked so I'll take it from here
    ==
    I am trying to build with Provision for iOS. I have the correct Provision, certificate and Device but when building I receive this error message:

    [2013-11-13 10:01:35.464] Mist version: 2013.3.1111.1 location: app.icenium.com
    [2013-11-13 10:01:35.467] Loading solution v2 ...
    [2013-11-13 10:01:37.917] Solution loading finished.
    [2013-11-13 10:02:09.320] Build solution started: v2
    [2013-11-13 10:02:52.486] Exception: Unexpected server error: After parsing a value an unexpected character was encountered: M. Path 'Output', line 1, position 276.

    I feel a bit stuck :-(

  2. Pete
    Pete avatar
    18 posts
    Member since:
    Apr 2013

    Posted 13 Nov 2013 Link to this post

    I am getting the same error when trying to build a development build with provision for iOS.  (I can run a production build for iTunes Connect.)  But I need to test first.  Is this a server issue?
  3. Pete
    Pete avatar
    18 posts
    Member since:
    Apr 2013

    Posted 13 Nov 2013 Link to this post

    Found the fix for this issue.  More searching brought up the release notes:
    http://docs.icenium.com/release-notes/v1-9-1

    There is a bug where it grabs the (it looks like) first certificate it sees, rather than grabbing your development certificate only.  So you have to temporarily remove your distribution certificate to run dev builds.

    To fix this, you have to:
    * Go to the Welcome menu in the top right corner;
    * Select "Options";
    * "General" tab; 
    * Under "Cryptographic Identities" select your production Distribution certificate and first do a backup.  Click on the export button to download the certificate.
    * After it is downloaded, then click the delete button next to the Distribution certificate, so that all that remains is your Development certificate. 

    Then you can run a dev build.  When you're done, you have to re-import your Distribution certificate in order to publish to iTunes Connect.
  4. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 14 Nov 2013 Link to this post

    Hi guys,

    Thanks for sharing your findings in this thread. However this problem should be fixed in the latest 1.9.1 version, that is why you found it in the release notes. If you are able to steadily reproduce this on your machine, we would appreciate if you provide more info:
    • Does this happen on any project you try to build or only with specific projects?
    • What is your OS, browser and browser version?
    • How many certificates do you have and what type is the one that is preselected?

    Regards,
    Steve
    Telerik
    You've missed the Icenium Visual Studio Integration keynote? It has been recorded and posted here.
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
  5. Cedric
    Cedric avatar
    7 posts
    Member since:
    Jul 2013

    Posted 14 Nov 2013 Link to this post

    Only one project. To fix this, I created a new empty project which I could build and moved all my code to it.

    Chrome Version 31.0.1650.48 on Max OS X 10.9 (Maverick)

    I have 3 certificates - I wanted to use a development one.

    Hope it helps.
  6. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 15 Nov 2013 Link to this post

    Hello Cedric,

    Thanks for the details, we were able to reproduce the problem and identified the issue, which is now logged for fixing. Basically migrating your project to a new one resolved the exception as new projects do not have iOS Code Signing Identity set by default. So when you build your app, the proper certificate is used. The issue is that if you have a certificate is selected in the iOS project properties, Mist would wrongly use that certificate instead of the selected in the build dialog. Selecting the proper certificate in that dropdown would result in successful build.

    Regards,
    Steve
    Telerik
    You've missed the Icenium Visual Studio Integration keynote? It has been recorded and posted here.
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
  7. Pete
    Pete avatar
    18 posts
    Member since:
    Apr 2013

    Posted 15 Nov 2013 Link to this post

    Thanks for looking into this Steve.  Here was my experience...

    I had a project that I was working in previously with no issues.  I could export with the Dev certificate using the Run -> Build menu option, and then right after use Publish -> App Store and generate an app store IPA file.  After the update, and after using publish, I had to return to my project for a bug fix.  It was at that time that I tried to generate a new Dev build using Run -> Build and received the "unexpected character" message.

    To fix it, I opened my list of Cryptographic Identities, and noticed that my production/distribution identity was listed first.  I exported that, downloaded the distribution identity as backup, then deleted the distribution identity and used Run -> Build again to successfully build the dev app.  After fixing and testing my bug fix I reimported the distribution identity and clicked on Publish -> App Store.  This time, it gave me the same error, so I noted that the distribution entity had been added to the bottom of my list of Cryptographic Identities, and now the Dev identity was listed first in the list.  So I exported my dev identity and downloaded it as a backup, and then deleted the Dev identity.  from that point on I was able to use Publish -> App Store to create my new production package.  That is why I think it is grabbing the first identity in the list, regardless of type.

    I should also note that I checked the identity being used in the dropdown, when trying the failing builds.  The dropdown read the correct identity, but that ended up not being the entity used for the build attempt.

    Thanks again.  I'm glad there's a workaround, but I look forward to not having to manually swap identities.
  8. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 18 Nov 2013 Link to this post

    Hello Pete,

    All the steps you have listed are basically a long way workaround for the one I've explained in the previous post. Until we address this bug in Mist, please open the project properties and select the certificate you wish to use according to the build you would be starting.

    Sorry for the temporary inconvenience once again!

    Regards,
    Steve
    Telerik
    You've missed the Icenium Visual Studio Integration keynote? It has been recorded and posted here.
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
Back to Top