Hyperlink Manager URL Encoding issue

4 posts, 1 answers
  1. Fit2Page
    Fit2Page avatar
    345 posts
    Member since:
    Feb 2007

    Posted 09 Nov Link to this post

    On the Telerik site, hyperlinks are not encoded when saving the link in Linkmanager, see screenshot #1.

     

    In our application the %20 are once more encoded to %2520 when OK-ing the Linkmanager, see screenshot #2.

     

    All ContentFiltering is set Standard, just like the demo site...I am using EditorDialogs/LinkManager.ascx though.

     

    Marc

     

  2. Answer
    Vessy
    Admin
    Vessy avatar
    1388 posts

    Posted 14 Nov Link to this post

    Hi Marc,

    A possible reason for this behavior can be if the external dialogs in you application are not taken from the same version like the Telerik DLLs are. Can you, please, verify that all Telerik-related resources are taken from version 2016.3.1027? If this is not the case, please, send us a simplified runnable project where the problem can be observed so we can examine the cause for it further.

    Regards,
    Vessy
    Telerik by Progress
    Check out the new UI for ASP.NET Core, the most complete UI suite for ASP.NET Core development on the market, with 60+ tried-and-tested widgets, based on Kendo UI.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Fit2Page
    Fit2Page avatar
    345 posts
    Member since:
    Feb 2007

    Posted 14 Nov in reply to Vessy Link to this post

    Hi Vessy,

     

    2016.3.1027 solves the problem.

     

    Thanks, Marc

  5. Vessy
    Admin
    Vessy avatar
    1388 posts

    Posted 15 Nov Link to this post

    Hi,

    You are totally welcome, Marc - I am glad my suggestion was helpful for you.

    Regards,
    Vessy
    Telerik by Progress
    Check out the new UI for ASP.NET Core, the most complete UI suite for ASP.NET Core development on the market, with 60+ tried-and-tested widgets, based on Kendo UI.
Back to Top