http://demos.telerik.com/silverlight/ is not working

9 posts, 0 answers
  1. Tad
    Tad avatar
    3 posts
    Member since:
    Jul 2013

    Posted 13 May 2015 Link to this post

    Unhandled Error in Silverlight Application 

    Just wondered if you knew...

  2. Martin
    Admin
    Martin avatar
    1099 posts

    Posted 14 May 2015 Link to this post

    Hello Tad,

    We are not aware of the reported error. Can you please tell us what is the set up of your machine (OS) and which browser you are using. If you think of any additional information that might be helpful to reproduce the error please share it with us.

    Regards,
    Martin
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. DevCraft banner
  4. Tad
    Tad avatar
    3 posts
    Member since:
    Jul 2013

    Posted 14 May 2015 Link to this post

    I'm using Windows 7. The error happens in Chrome Version 42.0.2311.135 m and in IE Version 11.0.9600.17728. I have Silverlight 64-bit Version 5.1.30514.0 installed.

     The error message is:

    Unhandled Error in Silverlight Application

    Code: 2103

    Category: InitializeError

    Message: Invalid or malformed application: Check manifest

  5. Martin
    Admin
    Martin avatar
    1099 posts

    Posted 14 May 2015 Link to this post

    Hi Tad,

    We tested our demos website also under Windows 7 but we were not able to reproduce the reported error as you can see in the linked video. The most common reason for this error in Silverlight is that if after creating a runnable project you change its namespace in code but not in the config and XAML files. If there is a namespace's name that is changed in the latest version of the demos it is possible the browsers cache to store information about the old demos and this might lead to the described issue. However, this is merely a shot in the dark, so I am going to ask you if you can elaborate more on your case by trying the following and let me know if there is any change in the website's behavior:
    • Clear the cache of your browsers
    • Reinstall the Silverlight framework
    • Test the demos on a different machine with similar set up
    • Disable any security software that might block the access to the Silverlight plugin

    If you think of some additional information, plugin or set up that you have on your machine which could be the reason for this, please share it with us.

    Regards,
    Martin
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  6. Mike
    Mike avatar
    6 posts
    Member since:
    Sep 2012

    Posted 14 May 2015 Link to this post

    Just to chime in, I just used the site successfully about 5 minutes ago.

     

    However, as expected, in Chrome 42.0.2311.152 m it told me I needed to install Silverlight.  It's already installed, but Google has implemented that total NPAPI block, so that's the (misleading) message Silverlight apps show, now.  May want to include a message indicating such, and perhaps the workaround (until Chrome 45) of:

    • Go to chrome://flags/#enable-npapi
    • Choose Enable
    • At the bottom left of your screen, click Relaunch Now

     

    Using IE 11, I have the site open and running fine right now.

  7. Tad
    Tad avatar
    3 posts
    Member since:
    Jul 2013

    Posted 14 May 2015 Link to this post

    Looks like our firewall is blocking the .xap file.

    Sorry for the false alarm.

  8. Sia
    Admin
    Sia avatar
    667 posts

    Posted 15 May 2015 Link to this post

    Hi,

    We are happy to hear that you managed to isolate the reason of this behavior. Please do not hesitate to contact us again if you still have issues.

    Regards,
    Sia
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  9. Danny
    Danny avatar
    2 posts
    Member since:
    Sep 2013

    Posted 12 Jun 2015 Link to this post

    We just tested our reporting site (which utilizes the Telerik report viewer) using an installation Chrome 45 (a developer version which eliminates all access to NPAPI - no manual override - and is slated for delivery in Sept-2105).  The report viewers failed to display anything (no hard errors, just a blank white space where the report viewer should have been).

    Do you have plans to support the no-NPAPI versions of Chrome that are in our future?

  10. Stef
    Admin
    Stef avatar
    3041 posts

    Posted 15 Jun 2015 Link to this post

    Hi Danny,

    If you are using Telerik Reporting Silverlight ReportViewer, please test the application in other browsers like IE11 as the issue might be related to missing styles. As of Q1 2014 the SL viewer uses only implicit styles, and if the required XAML theme files are not loaded, the viewer will not be displayed.
    For more details check How to: Add report viewer to a Silverlight application.


    About Silverlight support in Chrome, you can add logic for browser detection and display a page with the HTML5 Report Viewer when Chrome is detected. More details how the HTML5 viewer works are available in this forum thread.

    Regards,
    Stef
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top
DevCraft banner