html problem

9 posts, 1 answers
  1. sircutbreaker
    sircutbreaker avatar
    111 posts
    Member since:
    Oct 2007

    Posted 07 May 2008 Link to this post

    Weird thing I noticed.. I developed a webpage that has lists of people to send an email to... I am able to create the html in dreamweaver, Then I used the RadEditor to paste the html in there, which belongs to a web page i made as a flyer... (the page is posted live on a server...) i changed all the links to absolute...
    then there is a save button so the radeditor's html is saved to the db..

    funny thing is... when i access the page from SAFARI... and load up the radeditor... switch to html mode (so i can see the tags..) everything is fine...

    When i do the same thing from any other browser... well...  the abolsute part of the link is REMOVED...

    i cannot understand this... for the life of me... i checked the database (MSSQL) and i store the html there as ntext.... and when i paste the field into a notepad, the links are there in full...

    on safari, or raw from the db... the html reads like this:

    <img height=20 alt="" src="http://maximlrg.com/invite/images/camo_01.jpg" ....>

    when i go to the same page from ie 6,7, firefox,or opera it looks like this:
    <img height=20 alt="" src="/images/camo_01.jpg"...>

    why it removes the first part of the link is my question...

    it HAS to have the link because the picture is showing when i go to view mode.. and the images folder is nowhere near that directory...

    very odd...


    Can anyone shed any light on this?

    Jeff





  2. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 10 May 2008 Link to this post

    Hi Jeffrey,

    By default, Internet Explorer converts all relative links to absolute. To override this IE behavior RadEditor converts by default all absolute links/image urls to relative using a client side filter. To disable this editor's client-side filter use the DisableFilter server-side method like this:

    RadEditor1.DisableFilter(EditorFilters.MakeUrlsAbsolute);

    Therefore the editor will keep the absolute links and will not make them relative.

    Best regards,
    Rumen
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. sircutbreaker
    sircutbreaker avatar
    111 posts
    Member since:
    Oct 2007

    Posted 13 May 2008 Link to this post

    I was not able to pull the disablefilter up... perhaps the version i am using is not as current as the one you are referring to...

    As long as i use safari, everything works as expected...

    But at least i know that there is a filter causing this behavior.

    Any other suggestions to remedy this?


    regards,

    Jeff
  5. sircutbreaker
    sircutbreaker avatar
    111 posts
    Member since:
    Oct 2007

    Posted 13 May 2008 Link to this post

    Ah, I seem to have found what you were describing... but its not in the same context...

    the command i found to remedy the situation was:

    reBody.StripAbsoluteImagesPaths = false;

    Thank you for placing me on the correct path to solve this. :)

    Regards,

    Jeff
  6. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 13 May 2008 Link to this post

    Hello Jeffrey,

    Could you please check the RadEditor version used in your project and write it here? You can do that by right clicking on the Telerik.Web.UI.dll file in the bin folder -> Properties -> Version.

    If the version is older than 2008.1.415, please upgrade the Telerik.Web.UI.dll to the latest one and the

    RadEditor1.DisableFilter(EditorFilters.MakeUrlsAbsolute);

    code will work as expected.

    Please, let me know if you are using RadEditor classic (RadEditor.Net2.dll). The solution for this editor is other.

    All the best,
    Rumen
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  7. sircutbreaker
    sircutbreaker avatar
    111 posts
    Member since:
    Oct 2007

    Posted 30 Aug 2008 Link to this post

    Revisiting this issue... I am now using the q2 version of the asp.net controls...

    I have another site with a back end using the radeditor so that a client can create emails for bulk mailing...

    i enabled the link manager in the editor...

    i have the line:

    RadEditor1.DisableFilter(EditorFilters.MakeUrlsAbsolute);

    in the page load....

    yet, when i save the content... it is still removing the http://<sitename>

    please advise...

  8. Answer
    Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 01 Sep 2008 Link to this post

    Hi,

    If you use Telerik.Web.UI.dll (v2008.2.826 or v2008.2.723) and want to produce absolute paths then you need to enable the MakeUrlsAbsolute, but not to disable it. Try the following code:

    RadEditor1.EnableFilter(Telerik.Web.UI.EditorFilters.MakeUrlsAbsolute);


    Best regards,
    Rumen
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  9. vajinder singh
    vajinder singh avatar
    2 posts
    Member since:
    Mar 2010

    Posted 02 Mar 2010 Link to this post

    Hi,
    I am facing the same problem.
    Currently i am using telerik version "RadControls for ASP.NET AJAX Q2 2009".

    Is this issue solved in that telerik version? 
  10. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 02 Mar 2010 Link to this post

    Hi Vajinder,

    Could you please specify the exact problem that you experience with Q2 2009?
    If you want to produce absolute paths then enable the MakeUrlsAbsolute filter

    RadEditor1.EnableFilter(Telerik.Web.UI.EditorFilters.MakeUrlsAbsolute);

    All the best,
    Rumen
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017