How to hide the bottom section of the editor

12 posts, 0 answers
  1. Jeffery
    Jeffery avatar
    18 posts
    Member since:
    Sep 2006

    Posted 11 Jan 2008 Link to this post

    Hi,

    I'd like to hide the bottom section of the editor, just like the form I am writing now (http://www.telerik.com/community/forums/new-forum-post/b314Z-e.aspx).  Is that possible?

    Thanks,
    Jeffery Sun
  2. Jeffery
    Jeffery avatar
    18 posts
    Member since:
    Sep 2006

    Posted 11 Jan 2008 Link to this post

    Nerve mind.  I figured it out.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. HHH
    HHH avatar
    42 posts
    Member since:
    Feb 2008

    Posted 19 Mar 2008 Link to this post

    Hey hi,

    How u do it , i wanna hide  the HTMl mode in RADEDITOR (Prometheus)
    i dont find anything..

    thanks
    HHH.
  5. Rumen
    Admin
    Rumen avatar
    12846 posts

    Posted 20 Mar 2008 Link to this post

    Hi,

    You can hide the Html mode of RadEditor "Prometheus" by setting EditModes enum property to "Design,Preview", e.g.

    <telerik:RadEditor runat="server" ID="RadEditor1" EditModes="Design,Preview"></telerik:RadEditor>

    C#:
    RadEditor1.EditModes = EditModes.Design | EditModes.Preview;

    VB.NET:
    RadEditor1.EditModes = EditModes.Design Or EditModes.Preview

    Let me know if you want to hide the Real Time Html View module.

    Best regards,
    Rumen
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  6. David Penny
    David Penny avatar
    174 posts
    Member since:
    Jun 2006

    Posted 20 Mar 2008 Link to this post

    Hi,

    I was just about to post on exactly the same topic.  However, I'm not sure your answer is exactly what I am looking for.  I would like to show just the editing area of RadEditor - my page has the edit area only shown as the top half of the editor, then a couple of lines and a large empty area at the bottom.  I'm not sure what this area is so do not know what to change to hide or reduce it.

    I have tried setting the Edit Modes Property to Design and also Design,Preview but the Editor still displays with the extra space at the bottom.

    David Penny
    Pillar Software

  7. Rumen
    Admin
    Rumen avatar
    12846 posts

    Posted 20 Mar 2008 Link to this post

    Hi Pillar,

    The mentioned a couple of lines and the large empty area at the bottom of the editor are the editor's modules. They are enabled on selection in the content area, for example when you click on a link or an image.

    You can easily remove them in

    RadEditor "Prometheus" and RadEditor Classic:

    C#
    RadEditor1.Modules.Clear();

    VB.NET
    RadEditor1.Modules.Clear()

    If you use a ToolsFile.xml to populate the editor's tools then just delete the MODULES tags and their inner tags.

    Greetings,
    Rumen
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  8. David Penny
    David Penny avatar
    174 posts
    Member since:
    Jun 2006

    Posted 20 Mar 2008 Link to this post

    Thanks Rumen,

    that did the trick.
  9. HHH
    HHH avatar
    42 posts
    Member since:
    Feb 2008

    Posted 20 Mar 2008 Link to this post

    Thanks Man..
    thats the one i was looking for ..thanks

  10. HHH
    HHH avatar
    42 posts
    Member since:
    Feb 2008

    Posted 20 Mar 2008 Link to this post

    Thanks Rumen
  11. Rumen
    Admin
    Rumen avatar
    12846 posts

    Posted 20 Mar 2008 Link to this post

    You are welcome, guys :)

    I am glad to help.


    Kind regards,
    Rumen
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  12. Bram van den Broek
    Bram van den Broek avatar
    6 posts
    Member since:
    May 2005

    Posted 28 May 2008 Link to this post

    Hello,

    Is there a way to do a editor.modules.clear() in .skin files? Like you would clear collections in .config file?:

    <modules>
        <Clear />
    </modules>

    With kind regards,

    Bram van den Broek
  13. Rumen
    Admin
    Rumen avatar
    12846 posts

    Posted 28 May 2008 Link to this post

    Hi Bram,

    You should declare a telerik:EditorModule inner tag with empty Name attribute. Here is a way to hide the editor's modules in a .skin file:

    <%@ Register Assembly="Telerik.Web.UI" Namespace="Telerik.Web.UI" TagPrefix="telerik" %>

    <telerik:radeditor runat="server" SkinID="Editor1">
        <Modules>
            <telerik:EditorModule Name="" />
        </Modules>
    </telerik:radeditor>

    Best regards,
    Rumen
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017