How to enable tabs inside a cell editor

3 posts, 1 answers
  1. ManniAT
    ManniAT avatar
    877 posts
    Member since:
    Nov 2003

    Posted 22 Aug 2009 Link to this post

    Hi,

    to edit custom data I provide my own editor (some controls for the data).
    Assume there are some checkboxes. I uncheck (by mouse) the first and then I decide to use keyboard input.
    So I press tab to go to the next checkbox (or whatever there is in my "user control").
    But instead of selecting the next element in my editor it leaves the cell.

    Did I oversee some property I have to set - or does this mean "RadGridView" has limited keyboard support?

    If you want to see what I mean you can check (after screening) my code library post here:
    http://www.telerik.com/community/code-library/wpf/gridview.aspx (custom editor...)

    Regards

    Manfred
  2. Answer
    Nedyalko Nikolov
    Admin
    Nedyalko Nikolov avatar
    871 posts

    Posted 26 Aug 2009 Link to this post

    Hello ManniAT,

    Generally, RadGridView handles TAB key down in order to enable "smart TAB navigation feature". So if you do not handle TAB key down event, RadGridView moves focus to the next (according with TAB direction) GridViewCell. Fortunately in WPF you can handle properly TAB navigation with a few lines of code.

    I'm attaching a modified version of the example from your code library for a reference. I've changed only GVAccessTimeEditor.cs file.

    Hope this helps.

    Kind regards,
    Nedyalko Nikolov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. UI for WPF is Visual Studio 2017 Ready
  4. ManniAT
    ManniAT avatar
    877 posts
    Member since:
    Nov 2003

    Posted 26 Aug 2009 Link to this post

    Hi Nedyalko,

    OK - this means RadGridview does "special key handling" and therefore declarative setting of the tab configuration (local, etc.) doesn't work.
    Good to know.

    Thank you for the workaround - it works as expected

    Manfred
Back to Top