How to do 24 hour in RadTimePicker

5 posts, 0 answers
  1. Flea#
    Flea# avatar
    10 posts
    Member since:
    Apr 2009

    Posted 16 Dec 2010 Link to this post

    I have a RadTimePicker that I would like to use 24 hour format on. I have the format in 24 hours, but when I click 13:00 it puts 1:00 p.m. in the box. How can I get it to put the 24 hour format in the box?

    <telerik:RadTimePicker ID="ddlTravelStart"
        runat="server"
        TimeView-TimeFormat="HH:mm" >
    </telerik:RadTimePicker>

  2. Princy
    Princy avatar
    16662 posts
    Member since:
    Mar 2007

    Posted 16 Dec 2010 Link to this post

    Hello,

    The TimeView-TimeFormat set the format for the Pop-Up only. In order to set the desired format for the input field,  you need to set the DateInput-DateFormat as shown below.

    Mark-up:

    <telerik:RadTimePicker ID="ddlTravelStart" runat="server"  DateInput-DateFormat="HH:mm" TimeView-TimeFormat="HH:mm">
    </telerik:RadTimePicker>

    Thanks,
    Princy.

  3. Flea#
    Flea# avatar
    10 posts
    Member since:
    Apr 2009

    Posted 17 Dec 2010 Link to this post

    Thank you Princy, that worked!

  4. K10
    K10 avatar
    5 posts
    Member since:
    Feb 2013

    Posted 08 Apr 2013 Link to this post

    I want to set RadTimePicker's default time to 1.00 PM.
    How can I set??

    My RadTimePicker
     <telerik:RadTimePicker ID="AutomatedTimePicker" runat="server" Culture="English (United States)"   DateInput-DateFormat="HH:mm" Width="70px" Skin="Vista">
        <TimeView ID="TimeView1" runat="server" CellSpacing="-1" EndTime="21:00:00" StartTime="08:00:00">    </TimeView>
     </telerik:RadTimePicker>

  5. K10
    K10 avatar
    5 posts
    Member since:
    Feb 2013

    Posted 08 Apr 2013 Link to this post

    Answer to above question

    By setting the TimeFormat property you can show a 12 hour clock.
    <TimeFormat="hh:mm tt" >

Back to Top