How to disable the Image Editor?

12 posts, 1 answers
  1. Wesley
    Wesley avatar
    7 posts
    Member since:
    Sep 2007

    Posted 17 Apr 2008 Link to this post

    I've checked the documentation, but I don't see anything about disabling the "Image Editor" feature of the Image Manager dialog.  Can it be done?

  2. Answer
    Lini
    Admin
    Lini avatar
    2144 posts

    Posted 18 Apr 2008 Link to this post

    Hi,

    Unfortunately, there is no property to control the Image Editor tool appearance yet. I think this will be added in the next service pack release via a server-side property.

    All the best,
    Lini
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Panos
    Panos avatar
    5 posts
    Member since:
    Oct 2008

    Posted 31 Oct 2008 Link to this post

    i have the last version, and i set the ImageManager-EnableImageEditor property of RadEditor to
    "False"

    and also ImageManager EnableImageEditor property to "False" but if i click an image the Image Editor button appearance  is this bug?
  5. Lini
    Admin
    Lini avatar
    2144 posts

    Posted 31 Oct 2008 Link to this post

    Hello,

    I think this is a known issue with the image manager dialog in the current release. It will be fixed for the next official RadControls for ASP.NET AJAX release - Q3 2008, which is scheduled for next week. I think that the beta build for Q3 2008 we have on the site also includes the fix (if you wish to update right away).

    Kind regards,
    Lini
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  6. Panos
    Panos avatar
    5 posts
    Member since:
    Oct 2008

    Posted 03 Nov 2008 Link to this post

    thx
    Hellas Internet Team

    ps. this bug report adds me "Telerik points"?
  7. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 03 Nov 2008 Link to this post

    Hi Panos,

    We give points only for newly reported bugs. Since, this is a known problem and it was reported before by another customer, our policies do not allow us to add Telerik points to your account for this bug.


    Kind regards,
    Rumen
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  8. Jan Rangul
    Jan Rangul avatar
    1 posts
    Member since:
    Jun 2007

    Posted 01 Jun 2010 Link to this post

    Hi, i use the newst rad editor ajax, and i can still not dissable the appearance of the image editor dialogue.
  9. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 01 Jun 2010 Link to this post

    Hi Jan,

    You can very easy disable the Image Editor button in the latest Q1 2010 SP2 build by setting ImageManager-EnableImageEditor="false", e.g.

    <telerik:RadEditor ID="RadEditor1" runat="server" ImageManager-EnableImageEditor="false">
            <ImageManager ViewPaths="~/Images" UploadPaths="~/Images" EnableImageEditor="false" />
    </telerik:RadEditor>


    Sincerely yours,
    Rumen
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  10. Kenneth
    Kenneth avatar
    4 posts
    Member since:
    Aug 2011

    Posted 15 Feb 2012 Link to this post

    Apologies for replying to an old thread but I am having trouble removing the Image Editor link from the Image Manager control. I have set both properties as illustrated in Rumen's post and I have also set them individually but the Image Editor link is still enabled whenever I click on an image.

    The only thing that I can see that is different in my code is the fact that I am using a custom content provider but that shouldn't make any difference should it?

  11. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 17 Feb 2012 Link to this post

    Hi,

    The ImageManager-EnableImageEditor="false" property should work even when a custom content provider is used.

    Nevertheless, you can hide this button completely by setting the DialogsCssFile property to point to a CSS file

    <telerik:RadEditor ID="RadEditor1" runat="server" DialogsCssFile="~/Dialog.css"></telerik:RadEditor>


    which contains the following CSS class:

    .icnImageEditor
    {
    display: none!important;
    }


    Best regards,
    Rumen
    the Telerik team
    Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
  12. Newton
    Newton avatar
    26 posts
    Member since:
    Sep 2005

    Posted 11 Dec 2013 Link to this post

    Hi,

    The property "EnableImageEditor=false" does not work yet. I'm using the latest version 2013.3.1114.45

    Regards,
    Newton
  13. Vessy
    Admin
    Vessy avatar
    1385 posts

    Posted 13 Dec 2013 Link to this post

    Hello Newton,

    I have tested the EnableImageEditor property of RadEditor, but everything is working as expected on my side with the latest version on the controls (2013.3.1114.45) - video. Could you, please, provide more detailed information regarding the specific scenario?
    • Are there any modifications made to the Editor on your page?
    • In which browser the ImageEditor buttons does not get disabled?

    Could you try to isolate the problem into a sample fully runnable project so we could investigate the exact configuration that breaks the functionality of the EnableImageEditor property?


    Looking forward to hearing from you,
    Veselina Raykova
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017