How to disable "snap to top visible item" on item tap?

4 posts, 0 answers
  1. André
    André avatar
    8 posts
    Member since:
    May 2014

    Posted 29 Jan 2015 Link to this post

    If I scroll a DataBoundListBox down, so that one item is half visible at the top and than tap on another item on the center of the screen, the DataBoundListBox "snaps" to the border of the first visible item. How do I avoid this? I don't want the ListBox to automatically scroll if I tap an item.

    Thanks! Sunny
  2. André
    André avatar
    8 posts
    Member since:
    May 2014

    Posted 29 Jan 2015 in reply to André Link to this post

    If I step throught the code, I did see that the ListBox calls "BringIntoView" internally with the top visible item passed in. Can I disable this behavior?
  3. DevCraft banner
  4. André
    André avatar
    8 posts
    Member since:
    May 2014

    Posted 30 Jan 2015 Link to this post

    Ups, posted to wrong board (wp7), moved to wp8 -> http://www.telerik.com/forums/replacing-listbox-with-databoundlistbox-and-adding-animation

    This Thread can be deleted! Thanks!
  5. Ves
    Admin
    Ves avatar
    2879 posts

    Posted 04 Feb 2015 Link to this post

    Hello André,

    We have provided a reply in the other forum thread. Just for the sake of completeness, here is the correct link: http://www.telerik.com/forums/how-to-disable-snap-to-top-visible-item-on-item-tap-8d3b8d3d5f87

    Best regards,
    Ves
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
Back to Top