How to disable default Ctrl+V paste behavior

3 posts, 1 answers
  1. Vic
    Vic avatar
    36 posts
    Member since:
    Aug 2012

    Posted 24 Oct 2012 Link to this post

    Hello,

    I'm looking for a way to disable the default Ctrl+V behavior, which simply creates a blank appointment (bypassing all validation).  I tried defining my own command bindings to override the default behavior as exemplified in the sample project included in this post  http://www.telerik.com/community/forums/silverlight/scheduleview/copy-paste-appointment.aspx;  however, I cannot find the appropriate namespace for CommandManager.SetCommandBindings().  System.Windows.Input.CommandManager does not contain a definition for SetCommandBindings, and I cannot find CommandManager under Telerik.Windows.Controls.   Likewise, when specifying <telerik:CommandManager.InputBindings> in XAML, I get 'The attachable property InputBindings was not found in type CommandManager'.  Am I missing something or is this only meant to work in Silverlight? 

    I'm using the latest Q3 release.

    Thanks in advance..
    Vic
  2. Answer
    Yana
    Admin
    Yana avatar
    4554 posts

    Posted 29 Oct 2012 Link to this post

    Hi Vic,

    The example in the forum is applicable only to Silverlight. Have you tried to disable the inline appointment editing (by setting IsInlineEditingEnabled property of the ScheduleView to false)? This should prevent the pasting behavior.

    Regards,
    Yana
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  3. UI for WPF is Visual Studio 2017 Ready
  4. Vic
    Vic avatar
    36 posts
    Member since:
    Aug 2012

    Posted 29 Oct 2012 Link to this post

    Thanks, Yana.  That seems to do the trick!
Back to Top