High CPU consumption on Client Side

3 posts, 0 answers
  1. Haderach
    Haderach avatar
    45 posts
    Member since:
    Dec 2006

    Posted 22 Aug 2008 Link to this post


    We are using the old version RadRotator on our website and we found outa quite strange issue on Firefox and on Firefox 1.5.
    When the RadRotator is moving the firefox process consums a very high part of CPU on client side.

    We tried the same thing on your demo website with nex RadRotator and we noticed exactly the same behoavior.

    We also tried on IE 6 and 7 but here, we can't notice anything about CPU usage.

    Why such a CPU usage on Firefox for the moving of RadRotator?

    Thank you for your help,
    Read you soon.
  2. Shaun Peet
    Shaun Peet avatar
    571 posts
    Member since:
    Aug 2004

    Posted 22 Aug 2008 Link to this post

    I've also noticed extremely high CPU usage in FF3 (although I did not test in other browsers).  It should be noted, though, the the rotators are far more performant in FF3 than they are in IE7 (as is just about every other client-side control).
  3. DevCraft R3 2016 release webinar banner
  4. Georgi Tunev
    Georgi Tunev avatar
    7207 posts

    Posted 25 Aug 2008 Link to this post

    Hi Haderach,

    I am afraid that this is something that we cannot change from our side. The problem in this case comes from the Firefox implementation - note that the code that is used for displaying the items is working fine in all other major browsers.

    Sincerely yours,
    Georgi Tunev
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Back to Top