Hiding indented area for details

5 posts, 0 answers
  1. Mike Dennis
    Mike Dennis avatar
    51 posts
    Member since:
    Mar 2006

    Posted 10 Sep 2009 Link to this post

    Is there a way to hide the area that the details tables get shifted over?  I am trying to make the detail table look like part of the main row.  I have ExpandCollapseColumn-Display set to false in the MasterTableView, so I don't see the expand column, but I am hoping that there is a way to remove the area that it is shifted right.
  2. Shinu
    Shinu avatar
    17764 posts
    Member since:
    Mar 2007

    Posted 10 Sep 2009 Link to this post

    Hi Mike,

    Here is help article which explains how to align columns in each level of hierarchical grid. Go through it and see whether it helps.
    Aligning columns in each level of hierarchical grid

    Thanks
    Shinu
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Mike Dennis
    Mike Dennis avatar
    51 posts
    Member since:
    Mar 2006

    Posted 11 Sep 2009 Link to this post

    That doesn't seem to fix my problem.  I saw that before and hadn't added the HorizontalAlign = Right part, but I just tried that without any luck.  My problem isn't really aligning columns, at least I don't think it is.  I have a grid set in bulk edit mode (although it current will only have one row), and I need a large text area for the user to enter any comments they have about the main row item.  The main row can vary in the number of columns that are visible.  When I set ExpandedCollapseColumn-Display to false, the expansion/contraction option goes away and the <td> for that is getting display:none, but the details area is getting rendered with the same <td> as I would have if the expansion column was visible.  With 9 visible columns and the expansion column hidden, the details column has an empty column and the rest is my text box with a colspan of 9 for that column.  Is there a way to hide that empty column?  I couldn't seem to find an example anywhere that did that..
  5. Mike Dennis
    Mike Dennis avatar
    51 posts
    Member since:
    Mar 2006

    Posted 11 Sep 2009 Link to this post

    I think that what I basically need is a way to just turn the display style to none for the left most cell in the details row.  I'm not sure what property I would need to set to have it render that way or if there even is a way to do that...
  6. Mike Dennis
    Mike Dennis avatar
    51 posts
    Member since:
    Mar 2006

    Posted 14 Sep 2009 Link to this post

    The answer to the post here solved my problem.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017