hide tab in LinkManager.ascx

7 posts, 0 answers
  1. mattc
    mattc avatar
    21 posts
    Member since:
    Aug 2007

    Posted 06 Apr 2009 Link to this post

    Hi all

    got something funny going on.
    Trying to hide the Anchor tab in the LinkManager dialog as per http://www.telerik.com/help/aspnet-ajax/disablingtabs.html

    If I put the Visible="false" attribute in the tab does not show but when I click the email tab I get the Anchor fieldset!?

    Tried with a fresh file and just made that one change and always does it. What am I doing wrong?

    Matt

    Q3 2008
    FF 3.08 and IE6
  2. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 14 Apr 2009 Link to this post

    Hi Matt,

    The problem is due to a change in the dialogs code and we will update the article and the description of the live example.

    To fix the problem open the \EditorDialogs\LinkManager.ascx file, locate the RadTabStrip control and set the PageViewID to all RadTab inner tags as shown below:

                <telerik:RadTabStrip ShowBaseline="true" ID="LinkManagerTab" runat="server" SelectedIndex="0" MultiPageID="dialogMultiPage">
                    <Tabs>
                        <telerik:RadTab Text="Hyperlink" PageViewID="hyperlinkFieldset" Value="Hyperlink">
                        </telerik:RadTab>
                        <telerik:RadTab Text="Anchor" PageViewID="anchorFieldset" visible="false" Value="Anchor">
                        </telerik:RadTab>
                        <telerik:RadTab Text="E-mail" PageViewID="emailFieldset" Value="E-mail">
                        </telerik:RadTab>
                    </Tabs>
                </telerik:RadTabStrip>

    Best regards,
    Rumen
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Amit
    Amit avatar
    5 posts
    Member since:
    Nov 2008

    Posted 10 Dec 2009 Link to this post

    Hello,

    I have updated my RadControls from ASP.NET AJAX Q3 2008 to ASP.NET AJAX Q3 2009, more precisely 2009.3.1208.20 version. I am trying to hide some of the tabs and some of the items in a tabs of dialogs  ie. Hyper link manager on RadEditor. The solution I found from this thread as well as on  link http://demos.telerik.com/aspnet-ajax/editor/examples/externaldialogspath/defaultcs.aspx  isnot working. It seems  code on LinkManager.ascx is changed again for Q3 2009. Can you please provide solution how to hide tabs as well as items on the tab.

    Thanks,
    Amit

  5. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 11 Dec 2009 Link to this post

    Hello Amit,

    The LinkManager.ascx file was updated and you should get its latest version from the new RadControls for ASP.NET AJAX installation. After that update its contents again to hide the desired tabs.

    BTW the LinkManager in the Customize Built-in Dialogs demo works as expected and you can see that in the attached video demonstrating my test. Please, clear your browser cache and this should fix the problem on your side.


    All the best,
    Rumen
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  6. Amit
    Amit avatar
    5 posts
    Member since:
    Nov 2008

    Posted 22 Dec 2009 Link to this post

    Rumen,
    Thanks for your reply.

    The problem was telerik version wasn't updated correctly from our end. But at this point we have decided to stay with Q3 2008 telerik version due to some css issues we have and after resolving that we will switch to latest telerik version.

    But by testing hyperlink manager-hiding tab and some of the field, we found that it has problem with IE 8.x. It doesn't show some input text field and get error on page as below:

    Message: Object doesn't support this property or method
    Line: 43
    Char: 1
    Code: 0
    URI: http://CLI.Cmap.Web/ScriptResource.axd?d=NIYT22e5fBl7lyRdIK2_xjsNQnjKy9ed8nQjiOcsWAjNBZRnvLwBWBD_nE4AcgefELok-YYf_XsiSvH4dfU76AIIkAgVNKma0WJJl4pKXxc1&t=12be488

    Message: Sys.ArgumentException:  does not derive from Sys.Component.
    Parameter name: type
    Line: 2707
    Char: 9
    Code: 0
    URI: http://CLI.Cmap.Web/ScriptResource.axd?d=kRKbyn8JlQ0ACvTx2wVrcXKSygWJDDT7WMNMTJiVWStY6k5kH5DHy9lfeHPa3CpBZFPipRoXgvbHi3w5mNrFPm-YnyoGurwBxy5s-1jjS0k1&t=fffffffff20fab49

    If you have some insight about this browser specific issue, will help to resolve this issue.

    Thanks,
    Amit

  7. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 23 Dec 2009 Link to this post

    Hi Amit,

    The problem is caused by the RadFormDecorator control in the editor dialogs. Updating the RadControls version to a newer release will fix the problem. I think that you should not experience problems to upgrade to a newer version but if you do not wish to upgrade, you can create a custom HTTP dialog handler, which inherits the default Telerik.Web.UI. DialogHandler and override the OnLoad() method, where you can try adding the

    <meta http-equiv="X-UA-Compatible" content="IE=7" />

    tag to the dialog page header. By default IE 8 should render all child iframes (RadWindow) in compat mode as well if the main page has the meta tag:

    C# code

            protected override void OnLoad(EventArgs e)
            {
                base.OnLoad(e);
                HtmlMeta hm = new HtmlMeta();
                hm.HttpEquiv = "X-UA-Compatible";
                hm.Content = "IE=7";
                Page.Header.Controls.Add(hm); 
            }

    The tags below should be also added to the web.config file:

    For IIS6:
    <system.web>
                    ...
                    <httpHandlers>
                                    ...
                                    <!--<add path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="Telerik.Web.UI.DialogHandler" validate="true"/>-->
                                    <add path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="Telerik.Admin.IECompatibilityHandler" validate="false"/>
                                    ...
                    </httpHandlers>
                    ...
    </system.web>

    For IIS7:
    <system.webServer>
                    ...
                    <handlers>
                                    ...
                                    <!--<add name="DialogHandler" path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="Telerik.Web.UI.DialogHandler"/>-->
                                    <add name="Telerik.Web.UI.DialogHandler.aspx" path="Telerik.Web.UI.DialogHandler.aspx" verb="*"                                 type="Telerik.Admin.IECompatibilityHandler" />
                                    ...
                    </handlers>
                    ...
    </system.webServer>

    Sincerely yours,
    Rumen
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  8. Roberto
    Roberto avatar
    2 posts
    Member since:
    Sep 2012

    Posted 08 Nov 2012 Link to this post

    Hallo,
    the solution suggested is still valid? I have test case application with the last  (2012.3.1016.40) version. I have tried to hide the anchor tab on linkmanager.ascx as suggested but it seems not to work.
    thanks
    Roberto
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017