Help with freezing hubtiles on pageload

2 posts, 0 answers
  1. GJ Kuz
    GJ Kuz avatar
    29 posts
    Member since:
    May 2011

    Posted 17 May 2012 Link to this post

    Dear Telerik Team,

    I have a panorama with a couple of panorama items. The hubtiles are on the second panorama item (index = 1). When the page with the panorama loads, I want to prevent the hubtiles from sliding unless the panorama item with the hubtiles is the default panorama item. I set the GroupTag and tried the RadHubTileService.FreezeGroup. But I no matter what the tiles still slide. When the page loads, I am on the first panorama item and I could see the hubtiles sliding on the second panorama item. How could I prevent this? I also have code to Free/UnFreeze in the SelectionChanged event of the Panorama control and that works perfectly.

    I also tried it on the sample Kiril put togther here. Doesn't work either. Could you please help me out here.

    Thanks,
    Gilles
  2. Victor
    Admin
    Victor avatar
    1351 posts

    Posted 18 May 2012 Link to this post

    Hi Gilles,

     From what I understood, the FreezeGroup/UnfreezeGroup methods don't work for some reason. The only thing that I can think of is that you are calling the hub tile service before your XAML is parsed. When are you calling the hub tile service? Is it before InitalizeComponent? Have you tried freezing the tiles on page loaded? If you tried all of these, please post a support ticket and send a sample app so that I may debug it and provide further assistance.

    I am looking forward to your reply.

    Regards,
    Victor
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. DevCraft banner
Back to Top