Help for SSO and skins for Telerik Controls.

4 posts, 0 answers
  1. Pradeep
    Pradeep avatar
    8 posts
    Member since:
    Oct 2010

    Posted 17 Jan 2011 Link to this post

    Can AnyOne Help me with the Skins. My application is garded by single Sign-On. If I apply SSo to my application the skins for the radcontrols ant applying. Please guid me in this.

    Thanks
  2. Prangadj
    Prangadj avatar
    174 posts
    Member since:
    Jan 2008

    Posted 18 Jan 2011 Link to this post

    Is other styles on page set when your SSo is on? May be it block all styles or such which come from .axd handler as with telericks. Test and try to use their skins as external to compare.

    Prangadj
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Pradeep
    Pradeep avatar
    8 posts
    Member since:
    Oct 2010

    Posted 21 Jan 2011 Link to this post

    Hi Prangadj,
         I tested placing one datepicker in the page and tested with SSO Enabled eventhough it is not grabbing the skin and images for Radcontrols in ASP.NET 2010.
    I tried with all the changes That i can and unable to solve this issue. You can view the pic. Which shows the view of the page with clienterror at the bottom of the browser  which says "Sys is undefined".

    Thanks.....
  5. Pradeep
    Pradeep avatar
    8 posts
    Member since:
    Oct 2010

    Posted 24 Jan 2011 Link to this post

    I got this issue resolved. That was an IIS Issue and below are the steps for resolving it. Thanks for your reply Prangadj .......

    Here’s the solution:

    http://forums.asp.net/p/1040236/3272631.aspx

    This one is a bit old, but it still applies to those who use SiteMinder (CA Netegrity) if you are having this problem. If this is already answered elsewhere in this thread sorry for the repeat in advance.

    Our problem manifested not as a "Sys" problem, but just that everything that was AJAX based didn't appear which, in our case, was about 70% of the information provided by our site. Not a good thing. A check of the weblogs showed every single call to an .axd file was returned as a 404 error. We turned off Siteminder and tried again and everything worked fine.

    What Blue Coat wrote in the article is correct, but you don't need to add the two empty files. As stated elsewhere it does work but it doesn't address the root of the problem. To make Siteminder stop blocking it:

    1. Go into your IIS Manager and right-click the root of your site and select Properties.
    2. Under Home Directory, click Configuration. 
    3. There should be a Wildcard entry for ISAPI6WebAgentDLL there (we are using CA Siteminder v6.xx so its there for us). Highlight it and click Edit.
    4. Make sure the checkbox for Verify that file exists is unchecked.
    5. Click through on OK.

    I was pulling my hair out trying to figure this one out, we were standing up a new server and everything mirrored the old one yet SSO worked on the old and not on the new. After a couple days of working with the helpdesk found out that the updated installation documentation we were provided omitted that fact to ensure you uncheck that checkbox, the older documentation we used to install on the old server had it. By default, when adding a Wildcard Mapping that checkbox is checked.


    Thans for you replies.... Thinking this would help others.......

    Thanks.

Back to Top