Height of cell

7 posts, 1 answers
  1. Susan
    Susan avatar
    137 posts
    Member since:
    Jul 2007

    Posted 22 Jul 2009 Link to this post

    I know there are tons of posts on this, and I think I have gone thru all I can find. I still cannot get it to work. I have a calendar in month view. The text of the appointments get cut off because the height of the appointment is too small. I want to increase this so I can see all the text. This is the latest I have tried.

     

     

    <style type="text/css">

     

     

    .RadScheduler_WebBlue .rsMonthView div.rsWrap

     

    {

     

    height:50px;

     

    }

     

    </style>

     

     


    The scheduler is very simple and read only.
     

     

     

     

    <telerik:radscheduler id="RadScheduler1" runat="server" Skin="WebBlue" DayStartTime="10:00:00" DayEndTime="20:00:00" Height="700px" >

     

     

     

    </telerik:radscheduler>

     

     

     

     

    Thanks so much.
    Susan

     

     

  2. Peter
    Admin
    Peter avatar
    6637 posts

    Posted 22 Jul 2009 Link to this post

    Hello Susan,

     Please use the following css styles:

        <style type="text/css">
            .RadScheduler .rsMonthView .rsWrap,
            .RadScheduler .rsMonthView .rsApt
            {
                height:auto !important;
            }
           
            .RadScheduler .rsMonthView .rsApt
            {
                position:static !important;
            }
        </style>

    This will cause the appointments height in Month View to be determined by the amount of text and there should be no need to set any height through code.


    All the best,
    Peter
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Susan
    Susan avatar
    137 posts
    Member since:
    Jul 2007

    Posted 22 Jul 2009 Link to this post

    This is getting closer! Is there any way to have the best of both worlds and still show some white space on the day when there are no events. Right now, in month view, there are no events the first couple of weeks so it is scrunched up. It would look much nicer if I could have a minimum height of the cell so at least the day would show up.

    Thanks.
    Susan
  5. Peter
    Admin
    Peter avatar
    6637 posts

    Posted 22 Jul 2009 Link to this post


    How about the following setting:

    <MonthView AdaptiveRowHeight="false" MinimumRowHeight="5" />

    Does this help?

    Regards,
    Peter
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  6. Susan
    Susan avatar
    137 posts
    Member since:
    Jul 2007

    Posted 22 Jul 2009 Link to this post

    It does not work. I put it in my page_load like:

    RadScheduler1.MonthView.AdaptiveRowHeight=

    False

     

    RadScheduler1.MonthView.MinimumRowHeight=

    "5"

    Thanks,
    Susan

     

  7. Answer
    Peter
    Admin
    Peter avatar
    6637 posts

    Posted 23 Jul 2009 Link to this post

    Hello Susan,

    Rereading your original post, I got another idea which might work better for this case. Can you try just setting RowHeight="50" and let us know if this is what you need?


    Kind regards,
    Peter
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  8. Susan
    Susan avatar
    137 posts
    Member since:
    Jul 2007

    Posted 23 Jul 2009 Link to this post

    Thanks Peter. That works great.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017