Headers not exporting in CSV

2 posts, 0 answers
  1. Seamus
    Seamus avatar
    1 posts
    Member since:
    Aug 2016

    Posted 02 Sep Link to this post

    Hey my headers sometimes are not attaching to a csv export at work. I am doing nothing differently. Example of scenario today. Logged in exported to csv and worked no problem. Reset the application repeated exact same steps with no difference and no headers. I've attached screenshots of the problem. Any pointers on how to fix this would be greatly appreciated.
  2. Katia
    Katia avatar
    240 posts

    Posted 05 Sep Link to this post

    Hi Seamus,

    When exporting to CSV format, Table/CrossTab item is rendered by expanding the table and creating a row and column for each row and column at the lowest level of detail. Due to the data denormalization(flattening) some Crosstab configurations will not be exported correctly.
    In this case, you can consider exporting to other formats (.xlsx) where the CrossTab's structure will be preserved.

    Check Design Considerations for CSV Rendering help article describing the known limitations and specifics of CSV rendering extension. Also, test resetting CSV Device Information Settings within your application.

    I hope this information will help.

    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. DevCraft R3 2016 release webinar banner
Back to Top