Grid - want *browser* scroll bar

4 posts, 0 answers
  1. Rebecca Rasmussen
    Rebecca Rasmussen avatar
    20 posts
    Member since:
    Mar 2007

    Posted 14 Aug 2009 Link to this post

    Hiya ... I seem to have the opposite issue of many in the searches I did on Grid and Width and Scrolling. Most seem to get the Browser horizontal scroll bar and want the grid to scroll not the page. With our last release we'd set our page to be a fixed width, and added a div around the Grids so that the grids could be scrolled independent of the page itself. Users are clamoring to have it back to the old way. Unfortunately, with our last release I also updated the control suite to the ASP .NET AJAX as well, and now when I remove the div we placed to scroll the grid, the page scroll does not appear.

    Instead, the grid takes up as much of the screen as is available, but the times when the width of the populated columns is greater than the page width, the grid border ends, the data columns extend off the page, but no browser horizontal scroll bar appears.

    Help? :)

    RadControls for ASPNET AJAX Q1 2009
    Microsoft Internet Explorer 7.x

    Below is the grid aspx ... I've tried setting both the full RadGrid and the MasterTableView and both to 100% and no change.

    <telerik:RadGrid ID="RadGrid1" runat="server" Skin="Office2007" 
        OnNeedDataSource="RadGrid1_NeedDataSource" AllowSorting="True"   
        EnableAJAX="True" EnableAJAXLoadingTemplate="True"  AllowMultiRowSelection="true" 
        LoadingTemplateTransparency="25" AllowPaging="false"   
        onitemcommand="RadGrid1_ItemCommand" GridLines="None"   
        onitemcreated="RadGrid1_ItemCreated" ShowFooter="True">  
        <PagerStyle AlwaysVisible="True" Mode="NextPrevAndNumeric" Position="Top" HorizontalAlign="Left" /> 
        <MasterTableView CommandItemDisplay="None" > 
            <ExpandCollapseColumn Visible="False" Resizable="False">  
                <HeaderStyle Width="20px" /> 
            </ExpandCollapseColumn> 
            <RowIndicatorColumn Visible="False">  
                <HeaderStyle Width="20px" /> 
            </RowIndicatorColumn> 
            <Columns> 
                <telerik:GridClientSelectColumn UniqueName="SelectCheckbox" /> 
            </Columns> 
            <CommandItemTemplate> 
                <div id="my_command_template">  
                    <asp:LinkButton ID="LinkButton_exportToExcel" runat="server"  CommandName="ExportToExcel" ToolTip="Export to Excel"></asp:LinkButton> <asp:CheckBox ID="CheckBox_ignorePaging" Checked="true" runat="server" Text="... include data on all pages." />   
                    &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;<asp:LinkButton ID="LinkButton_excludedAssets" runat="server" CommandName="ExcludedAssetsShow"></asp:LinkButton> 
                &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;<asp:LinkButton ID="LinkButton_exportToExcel_mass" runat="server"  CommandName="ExportToExcel_mass" ></asp:LinkButton>   
                </div> 
            </CommandItemTemplate> 
        </MasterTableView> 
            <HeaderContextMenu EnableTheming="True" Skin="Office2007">  
                <CollapseAnimation Duration="200" Type="OutQuint" /> 
            </HeaderContextMenu> 
        <AlternatingItemStyle BackColor="FloralWhite" /> 
            <ClientSettings> 
                <Selecting AllowRowSelect="True" /> 
            </ClientSettings> 
            <FilterMenu EnableTheming="True" Skin="Office2007">  
                <CollapseAnimation Duration="200" Type="OutQuint" /> 
            </FilterMenu> 
    </telerik:RadGrid> 
  2. Dimo
    Admin
    Dimo avatar
    8330 posts

    Posted 17 Aug 2009 Link to this post

    Hello Rebecca,

    If the browser scrollbar does not appear in your case, look for the following CSS rule somewhere in your website styles:

    html
    {
            overflow: hidden;
    }


    As for the second issue, with the RadGrid right border appearing before the right edge of the control, this is caused by the way the CSS specification is applied and can be resolved in two ways:

    1) set a pixel width to RadGrid
    or
    2) float the control with style="float:left". Don't forget to clear the float after the control


    Kind regards,
    Dimo
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Rebecca Rasmussen
    Rebecca Rasmussen avatar
    20 posts
    Member since:
    Mar 2007

    Posted 17 Aug 2009 Link to this post

    Thanks Dimo.

    I used the style="float:left" with clearing after and that seems to have at least stopped the grid border from ending "early".

    Unfortunately, I still have the issue with the page scroll bar. I do not have any "overflow" in my css. aspx, or cs files. I even tested with removing ALL my css and javascript references and still no browser scroll bar. {sigh} Anything else for which I should check?

    Thanks,
    Becca
  5. Dimo
    Admin
    Dimo avatar
    8330 posts

    Posted 18 Aug 2009 Link to this post

    Hello Rebecca,

    Please provide a runnable sample page, so that we can see what exactly is going on and provide further suggestions.

    Greetings,
    Dimo
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Back to Top