Grid shown as not styled

2 posts, 0 answers
  1. Yngve
    Yngve avatar
    17 posts
    Member since:
    Feb 2017

    Posted 14 Jun Link to this post

    Hi,

    When I browse to a certain page in my project with a Kendo Grid inside, I'm having a little issue. The grid is shown not visually styled momentarily when the page is loaded. It's just a little "flash" of it, and then it's rendered appropriately. Any idea how to fix this?

  2. Stefan
    Admin
    Stefan avatar
    912 posts

    Posted 16 Jun Link to this post

    Hello Yngve,

    This is not a known issue, but it is indeed theoretically possible if a page is too heavy or if there is something that slows down the browser before the Kendo UI widgets are initialized.

    Please check a similar thread in our forum:

    http://www.telerik.com/forums/how-to-fix-the-foucing-menu

    Optimising the page or hiding the elements are the only suggestions in this scenario, as the Kendo UI team has no control over it.

    If these approaches do not help, I can make a suggestion to check the nested HTML elements on the page.

    Depending on the scenario, there are some combinations of nested elements which will take more time to properly adjust the layout which can cause the flash of unstyled content. Please start removing nested elements from the page to determine which one is causing the issue.

    Still, if additional assistance is needed, please send a fully runnable example so I can test it and check if additional optimisations can be made.

    Regards,
    Stefan
    Progress Telerik
    Try our brand new, jQuery-free Angular 2 components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
Back to Top