Grid Paging Control Rendering Problem Below 1024 px Width

5 posts, 0 answers
  1. Russell
    Russell avatar
    8 posts
    Member since:
    Apr 2015

    Posted 11 Nov 2015 Link to this post

    When my page containing a grid control in MVC 5 with Bootstrap is shrunk to below 1024 px. in width, the grid paging control gets distorted as shown in the attached screenshots.

    I'm using a scaffolded MVC UI (2015.3.930) grid inside a default _layout body, i.e. it is being inserted inside a div with classes "container body-content" that have not been modified.

    I am using customized bootstrap themes that I generated using the Bootstrap theme builder and the Kendo UI theme builder. To the best of my knowledge, I have only altered colors in the custom themes, not anything related to padding or sizing.

    Anyone else seen this problems or have suggestions how to proceed or work around this behavior?

  2. Iliana Nikolova
    Admin
    Iliana Nikolova avatar
    2595 posts

    Posted 13 Nov 2015 Link to this post

    Hi Russell,

    This is a known issue in v2015.3.930, however it has been addressed - please test your application using Kendo UI Q3 2015 SP1 (v2015.3.1111) and let me know if you observe any further problems.

    Regards,
    Iliana Nikolova
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. UI for ASP.NET MVC is VS 2017 Ready
  4. Russell
    Russell avatar
    8 posts
    Member since:
    Apr 2015

    Posted 13 Nov 2015 in reply to Iliana Nikolova Link to this post

    Thank you, I will try it and report any remaining issues.
  5. Russell
    Russell avatar
    8 posts
    Member since:
    Apr 2015

    Posted 21 Nov 2015 in reply to Iliana Nikolova Link to this post

    Hello, the problem remains after upgrading to Q3 SP1. Would I need to re-generate my Kendo UI custom theme as well?
  6. Iliana Nikolova
    Admin
    Iliana Nikolova avatar
    2595 posts

    Posted 24 Nov 2015 Link to this post

    Hi Russell,

    I tried to reproduce the illustrated issue using Q3 SP1 release but to no avail (short screencast capture). Could you please try clearing the browser cache and let me know if this will help? 

    Regarding the custom theme,  Kendo UI ThemeBuilder modifies only the theme colors but not the dimensions - it should not be necessary re-generating the theme.

    Regards,
    Iliana Nikolova
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top
UI for ASP.NET MVC is VS 2017 Ready