Graphite crashing when loading

15 posts, 0 answers
  1. Adam
    Adam avatar
    1 posts
    Member since:
    Dec 2011

    Posted 19 Mar 2013 Link to this post

    I upgrade to the latest version of Graphite this morning and initially Graphite was crashing when it opened. The application would open then I would get a 'Icenium Graphite has stopped working' message before getting to the login screen.

    I did get it to work after deleting the …/AppData/Local/Telerik/BlackDragon folder and reloading the application.

    This is the error that came through on the event log: 

    Faulting application name: Icenium.Graphite.exe, version: 2013.1.319.1, time stamp: 0x5148233f
    Faulting module name: KERNELBASE.dll, version: 6.1.7601.18015, time stamp: 0x50b83c8a
    Exception code: 0xe0434352
    Fault offset: 0x0000c41f
    Faulting process id: 0x2228
    Faulting application start time: 0x01ce2480afb969fb
    Faulting application path: C:\Users\alex.hitchins\AppData\Local\Apps\2.0\W4BRLCM1.YK0\W29LW53H.6QB\icen..tion_1dcf05cf98ac3011_07dd.0001_040f0c87062b5224\Icenium.Graphite.exe
    Faulting module path: C:\Windows\syswow64\KERNELBASE.dll
    Report Id: ee94996b-9073-11e2-b647-005056c00008



    Application: Icenium.Graphite.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.Reflection.ReflectionTypeLoadException
    Stack:
       at System.Reactive.Concurrency.TaskPoolScheduler+<>c__DisplayClass2`1+<>c__DisplayClass4[[System.Reactive.Concurrency.Scheduler+Pair`2[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Reactive, Version=1.1.11011.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]].<Schedule>b__1()
       at System.Threading.ThreadHelper.ThreadStart_Context(System.Object)
       at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
       at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
       at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
       at System.Threading.ThreadHelper.ThreadStart()
  2. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 19 Mar 2013 Link to this post

    Hello Adam,

    We received your post at the time we were uploading the new 1.3 build of Icenium to our servers, so this might be related. The approach of cleaning the Graphite cache is correct and we're glad it resolved the problem.

    Sorry for the temporary inconvenience and please let us know should you encounter any other problems.

    All the best,
    Steve
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Pluralsight.
  3. Nick
    Nick avatar
    9 posts
    Member since:
    Jan 2013

    Posted 19 Mar 2013 Link to this post

    My Graphite also crashed this morning after an update but I can not find the folder /AppData/Local/Telerik/BlackDragon, if I search for Telerik all I get are the backups from the mobile devices and searching for BlackDragon returns nothing. I am using Windows 7
    Can you help
    Nick
  4. David Silveria
    David Silveria avatar
    234 posts
    Member since:
    May 2006

    Posted 19 Mar 2013 Link to this post

    Try to navigate to the folder directly i.e: C:\Users\nick\AppData\Local\Telerik\BlackDragon\.
    If you're not logged in as administrator and/or have uac enabled you might not have access to this folder, so logged in as Admin or disable UAC temporarily.
  5. Nick
    Nick avatar
    9 posts
    Member since:
    Jan 2013

    Posted 19 Mar 2013 Link to this post

    Sorry, I must be going blind! That is where I looked earlier, but it was there.
    All sorted now, deleting the folder and re installing did the trick.
    Thanks
  6. Benjamin
    Benjamin avatar
    4 posts
    Member since:
    Apr 2013

    Posted 09 Apr 2013 Link to this post

    I keep getting - "Application cannot be started.  Contact the Application Vendor"

    Here are the details:

    PLATFORM VERSION INFO
    Windows : 6.1.7601.65536 (Win32NT)
    Common Language Runtime : 4.0.30319.296
    System.Deployment.dll : 4.0.30319.1 (RTMRel.030319-0100)
    clr.dll : 4.0.30319.296 (RTMGDR.030319-2900)
    dfdll.dll : 4.0.30319.1 (RTMRel.030319-0100)
    dfshim.dll : 4.0.31106.0 (Main.031106-0000)

    SOURCES
    Deployment url : file:///C:/Users/bhall/AppData/Roaming/Microsoft/Windows/Start%20Menu/Programs/Telerik/Icenium%20Graphite.appref-ms%7C
    Deployment Provider url : http://cdn.icenium.com/live/graphite/publish/Icenium.Graphite.application

    ERROR SUMMARY
    Below is a summary of the errors, details of these errors are listed later in the log.
    * Activation of C:\Users\bhall\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Telerik\Icenium Graphite.appref-ms| resulted in exception. Following failure messages were detected:
    + Activation failed.
    + The system cannot find the file specified. (Exception from HRESULT: 0x80070002)

    COMPONENT STORE TRANSACTION FAILURE SUMMARY
    No transaction error was detected.

    WARNINGS
    There were no warnings during this operation.

    OPERATION PROGRESS STATUS
    * [4/9/2013 9:06:08 PM] : Activation of C:\Users\bhall\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Telerik\Icenium Graphite.appref-ms| has started.
    * [4/9/2013 9:06:08 PM] : Performing necessary update check as specified by the deployment.

    ERROR DETAILS
    Following errors were detected during this operation.
    * [4/9/2013 9:06:09 PM] System.Deployment.Application.DeploymentException (Activation)
    - Activation failed.
    - Source: System.Deployment
    - Stack trace:
    at System.Deployment.Application.ComponentStore.ActivateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)
    at System.Deployment.Application.SubscriptionStore.ActivateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)
    at System.Deployment.Application.ApplicationActivator.Activate(DefinitionAppId appId, AssemblyManifest appManifest, String activationParameter, Boolean useActivationParameter)
    at System.Deployment.Application.ApplicationActivator.ProcessOrFollowShortcut(String shortcutFile, String& errorPageUrl, TempFile& deployFile)
    at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
    at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)
    --- Inner Exception ---
    System.IO.FileNotFoundException
    - The system cannot find the file specified. (Exception from HRESULT: 0x80070002)
    - Source: System.Deployment
    - Stack trace:
    at System.Deployment.Application.NativeMethods.CorLaunchApplication(UInt32 hostType, String applicationFullName, Int32 manifestPathsCount, String[] manifestPaths, Int32 activationDataCount, String[] activationData, PROCESS_INFORMATION processInformation)
    at System.Deployment.Application.ComponentStore.ActivateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)

    COMPONENT STORE TRANSACTION DETAILS
    No transaction information is available.

    Can someone look into this please?  I have already uninstalled and re-installed 3 times.

    I'm not wanting to re-install every time I use the software.

    Thanks,

    Ben
  7. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 10 Apr 2013 Link to this post

    Hi Ben,

    Judging by the log you’ve provided, the problem might be due to a corrupt Microsoft ClickOnce app store. This is essentially the location on your hard drive where Windows caches per-user applications, such as Icenium Graphite. Try the following steps to address the problem:
    1. From the Windows Start menu choose Run (Or Windows Key + R)
    2. Enter the following , then click the OK button:
      %userprofile%\AppData\Local\Apps
      (e.g. C:\users\Username\AppData\Local\Apps)
    3. Delete the 2.0 folder
    4. Run or Install Icenium Graphite

    If the above does not help, can you share whether you’re logged in as a regular user or guest? If you drill down to the .exe file in the ClickOnce cache (search for Icenium.Graphite.exe in %userprofile%\AppData\Local\Apps) and double-click on it, does the application run?

    Hope this helps.

    Kind regards,
    Steve
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Kendo UI Dojo.
  8. Benjamin
    Benjamin avatar
    4 posts
    Member since:
    Apr 2013

    Posted 10 Apr 2013 Link to this post

    WOW!  Now it's REALLY screwed up.

    I deleted 2.0 and tried to run it.  (I couldn't even find the .exe file).  It installed, hung on install, crashed and then when I tried running it again, I got this:

    ----------------------------------------------------------------------------------------
    PLATFORM VERSION INFO
    Windows : 6.1.7601.65536 (Win32NT)
    Common Language Runtime : 4.0.30319.296
    System.Deployment.dll : 4.0.30319.1 (RTMRel.030319-0100)
    clr.dll : 4.0.30319.296 (RTMGDR.030319-2900)
    dfdll.dll : 4.0.30319.1 (RTMRel.030319-0100)
    dfshim.dll : 4.0.31106.0 (Main.031106-0000)

    SOURCES
    Deployment url : file:///C:/Users/bhall/AppData/Roaming/Microsoft/Windows/Start%20Menu/Programs/Telerik/Icenium%20Graphite.appref-ms%7C
    Deployment Provider url : http://cdn.icenium.com/live/graphite/publish/Icenium.Graphite.application

    ERROR SUMMARY
    Below is a summary of the errors, details of these errors are listed later in the log.
    * Activation of C:\Users\bhall\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Telerik\Icenium Graphite.appref-ms| resulted in exception. Following failure messages were detected:
    + Activation failed.
    + The system cannot find the file specified. (Exception from HRESULT: 0x80070002)

    COMPONENT STORE TRANSACTION FAILURE SUMMARY
    No transaction error was detected.

    WARNINGS
    There were no warnings during this operation.

    OPERATION PROGRESS STATUS
    * [4/10/2013 10:51:15 AM] : Activation of C:\Users\bhall\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Telerik\Icenium Graphite.appref-ms| has started.
    * [4/10/2013 10:51:15 AM] : Performing necessary update check as specified by the deployment.

    ERROR DETAILS
    Following errors were detected during this operation.
    * [4/10/2013 10:51:17 AM] System.Deployment.Application.DeploymentException (Activation)
    - Activation failed.
    - Source: System.Deployment
    - Stack trace:
    at System.Deployment.Application.ComponentStore.ActivateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)
    at System.Deployment.Application.SubscriptionStore.ActivateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)
    at System.Deployment.Application.ApplicationActivator.Activate(DefinitionAppId appId, AssemblyManifest appManifest, String activationParameter, Boolean useActivationParameter)
    at System.Deployment.Application.ApplicationActivator.ProcessOrFollowShortcut(String shortcutFile, String& errorPageUrl, TempFile& deployFile)
    at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
    at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)
    --- Inner Exception ---
    System.IO.FileNotFoundException
    - The system cannot find the file specified. (Exception from HRESULT: 0x80070002)
    - Source: System.Deployment
    - Stack trace:
    at System.Deployment.Application.NativeMethods.CorLaunchApplication(UInt32 hostType, String applicationFullName, Int32 manifestPathsCount, String[] manifestPaths, Int32 activationDataCount, String[] activationData, PROCESS_INFORMATION processInformation)
    at System.Deployment.Application.ComponentStore.ActivateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)

    COMPONENT STORE TRANSACTION DETAILS
    No transaction information is available.
  9. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 11 Apr 2013 Link to this post

    Hello Ben,

    This is the same exact error you've posted in your original post. Please answer the following questions, which we've asked in previous post:
    • Are you logged in as a regular user or guest? Try starting the setup.exe with elevated permissions after clearing the ClickOnce cache (see steps from previous post).
    • If you drill down to the .exe file in the ClickOnce cache (search for Icenium.Graphite.exe in %userprofile%\AppData\Local\Apps) and double-click on it, does the application run?
    • Do you have anti-virus scanning software enabled? In this thread, MS MVP reports this as a known issue especially with Kaspersky. Try disabling it temporarily and see whether that makes a difference.

    Kind regards,
    Steve
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Kendo UI Dojo.
  10. Benjamin
    Benjamin avatar
    4 posts
    Member since:
    Apr 2013

    Posted 11 Apr 2013 Link to this post

    Okay, 

    Answering your questions:  

    1:  I'm the sole admin for this machine.  
    2:  I did not find the .exe at the location given.  I did find:
            Icenium.Graphite.exe.cdf-ms
            Icenium.Graphite.exe.manifest
            Icenium.Graphite.exe.config
    3.  I do not have automatic anti-virus software running - I handle this manually.

    I was able to get this to run by doing the following:
            1:  Delete %userprofile%\AppData\Local\Apps
            2:  Uninstall Graphite
            3:  Run Setup - install

    After install:
            1:  I have successfully started the program and ran it
            2:  I shut it down
            3:  The next time I tried to run it I got the same error I posted previously.
            4:  Every attempt afterward results in a failure to run error

    The previous version did not do this.  It ran fine every time.

    I hope this information helps you find the bug - I like the software, but the newest version does not want to work for me.
  11. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 11 Apr 2013 Link to this post

    Hi Ben,

    Thank you for the clarification. In order to help further we would need the logs from ClickOnce, please follow the instructions from this blog post how to enable them. You can attach them to a free file sharing site and give the link here or send them on our support at icenium com email.

    While we're working with you to resolve this problem, you can use Mist IDE to continue working on your Icenium applications.

    Regards,
    Steve
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Kendo UI Dojo.
  12. Tino
    Tino avatar
    2 posts
    Member since:
    Aug 2013

    Posted 11 Sep 2013 Link to this post

    when i start Icenium  i got an error 


    Icenium Graphite has encountered a problem and needs to close.  We are sorry for the inconvenience.(A .png file is atteched)
     help me to resolve this .
    thanks in advance
  13. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 11 Sep 2013 Link to this post

    Hi Tino,

    We're sorry to hear you've hit such an unpleasant problem. Please try the suggestions from this thread and let us know if any has helped. If not, we would need answers to the questions we have asked in order to narrow down the possible culprit.

    Regards,
    Steve
    Telerik

    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
  14. Tino
    Tino avatar
    2 posts
    Member since:
    Aug 2013

    Posted 12 Sep 2013 Link to this post

    hi Steve
    Thanks for reply

    But It could not help me  and I am also try another  possible solution but that is not helpful
     So please suggest me a proper solution of this problem as soon as possible.

    Is this problem due  to Windows Genuine?
    or
    due to low Configuration of my System?
    {Configuration .png is attached}
     
  15. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 13 Sep 2013 Link to this post

    Hello Tino,

    Windows XP SP3 is a supported platform and you should also have Microsoft .NET Framework 4 Client Profile installed. If your machine complies with those and Graphite keeps crashing, please provide us with logs from Graphite (%LOCALAPPDATA%\Telerik\BlackDragon\Logs) and also from Windows event viewer. You can zip those and upload them to a free file sharing site and give us the link here or send to support[at]icenium[dot]com.

    Regards,
    Steve
    Telerik

    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
Back to Top