Graph configuration

4 posts, 0 answers
  1. Maxime
    Maxime avatar
    2 posts
    Member since:
    Sep 2015

    Posted 18 Apr Link to this post

    Hi,

    I'm creating a graph for a sale report, and there is some details that I'm not able to configure to my need. 

    See the attached image to see what I have up to now.

    There is two things missing :

    1) I'd like to increase the spacing between the Y axis and the first bar, to have a bit more room between the bar label at the top and the axis. I tried padding on the axis, the bar label, the plotarea and those doesn't seem to work.

     

    2) I have two sector in this case that have a value of zero, why don't they have a label shown? 

     

    Thanks for you help,

    Maxime

     

     

  2. Nasko
    Admin
    Nasko avatar
    909 posts

    Posted 21 Apr Link to this post

    Hello Maxime,

    1. The graph item will adjust the space allocated for each category slot automatically based on the number of categories and the X axis width. Manually interfering in this process is not supported.

    2. The data points with value of 0 will have labels by default. However, Null values will not produce lables for their corresponding data points and this behavior is by design. You can work around it by setting 0 instead of Null in your database, or replacing Null values with 0 using expressions. Please find attached a sample report demonstrating the approach.

    Regards,
    Nasko
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. DevCraft banner
  4. Maxime
    Maxime avatar
    2 posts
    Member since:
    Sep 2015

    Posted 21 Apr Link to this post

    Hi Nasko,

    Thanks for the information, unfortunately, I was not able to open the sample you sent me. I'm using Telerik Q1 2015 SP1.

    As for the answer for question number 2, it was already the case.

    The file data.png contains the bound data of the graph with the same data manipulation on it. First column is the X axis label, second the Y axis and last the datapointlabel.

    As you can see, I already had 0 as the value for these category.

     

    Is it something that changed since my version?

     

    Thanks for your help,

    Maxime

     

  5. Nasko
    Admin
    Nasko avatar
    909 posts

    Posted 21 Apr Link to this post

    Hello Maxime,

    The attached report demonstrates the current behavior. You are unable to open it because you are using an old version of Telerik Reporting. You will need a 2016 version of the Standalone Report Designer in order to open the report. You can download this version from your Telerik account.

    Regards,
    Nasko
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top