Getting Two tooltips...

2 posts, 0 answers
  1. Prasad
    Prasad avatar
    40 posts
    Member since:
    Sep 2011

    Posted 04 Dec 2012 Link to this post


    I am getting two tooltips for conrols .In the following scenario is ,

    If i mouse over on the Linkbutton i am getting only once after clicking / place the mouse on the link button then getting two tooltips.
    please find the attached snapshot ... I placed tooltip manager in the Masterpage . I have this issue in through out my application .. Please give replay ASAP


  2. Marin Bratanov
    Marin Bratanov avatar
    3562 posts

    Posted 05 Dec 2012 Link to this post

    Hi Prasad,

    I cannot see a screenshot attached so could you upload it again?

    Regarding the double tooltips issue itself - there are explicit measures taken so that only one RadToolTip can be visible on the page at any given time, so the behavior you report is rather strange. Can you confirm there aren't any JavaScript errors on the page? Do you have very high values set for properties like ShowDelay and HideDelay?

    Could you post here the minimal markup that reproduces the issue so I can actually investigate it if neither resolving any potential errors, nor reducing these properties to smaller values (you can simply remove them so they fall back to their defaults) helps?

    Also, if you have some custom handlers on the link button (especially ones that are supposed to show a radtooltip) could you remove them to see if the automatic tooltips left alone work as expected?

    Yet another point of interest is the browser you are having issues with - is it isolated to a certain browser, or is it happening across all of them?

    Kind regards,
    Marin Bratanov
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. DevCraft R3 2016 release webinar banner
Back to Top